{"answers":{"affected":"4 open source packages ship an affected version, including katalyst-koi.","exploited":"There is no known exploitation of CVE-2026-44511 in the wild and no public exploit code.","fix":"Upgrade katalyst-koi to a fixed version for your release line: 4.20.0 or 5.6.0.","what":"CVE-2026-44511 is a high-severity authentication bypass vulnerability in katalyst koi, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44511 and fix it if it is affected.\n\nWhat it is: CVE-2026-44511 is a high-severity authentication bypass vulnerability in katalyst koi, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44511 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- katalyst-koi (RubyGems): affected all versions; fixed in 4.20.0\n- katalyst-koi (RubyGems): affected all versions; fixed in 4.20.0\n- katalyst-koi (RubyGems): affected from 5.0.0; fixed in 5.6.0\n- katalyst-koi (RubyGems): affected from 5.0.0; fixed in 5.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44511/ (Markdown: https://insights.sbomify.com/CVE-2026-44511/index.md)","id":"CVE-2026-44511","markdown":"https://insights.sbomify.com/CVE-2026-44511/index.md","name":"CVE-2026-44511","record":{"aliases":["GHSA-4cx3-3c38-j9vv"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Rails admin framework","requires_auth":"none","summary":"Attackers can reuse admin session cookies after logout to maintain unauthorized access to administrative functions in Katalyst Koi.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"Katalyst Koi is a framework for building Rails admin functionality. Prior to 4.20.0 and 5.6.0, admin session cookies were not invalidated when an admin user logged out. An attacker with access to a valid admin session cookie could continue to access admin functionality after logout, until the cookie expired or session secrets were rotated. This vulnerability is fixed in 4.20.0 and 5.6.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Katalyst Koi: Session cookies can be replayed after user logout","id":"CVE-2026-44511","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"ONNX: Null Pointer Dereference in Upsample Version Converter Adapter (Zero Inputs)","id":"CVE-2026-44512"},"packages":[{"ecosystem":"RubyGems","fixed":["4.20.0"],"introduced":["0"],"last_affected":[],"package":"katalyst-koi","purl":null,"source":"GHSA-4cx3-3c38-j9vv"},{"ecosystem":"RubyGems","fixed":["4.20.0"],"introduced":["0"],"last_affected":[],"package":"katalyst-koi","purl":"pkg:gem/katalyst-koi","source":"GHSA-4cx3-3c38-j9vv"},{"ecosystem":"RubyGems","fixed":["5.6.0"],"introduced":["5.0.0"],"last_affected":[],"package":"katalyst-koi","purl":null,"source":"GHSA-4cx3-3c38-j9vv"},{"ecosystem":"RubyGems","fixed":["5.6.0"],"introduced":["5.0.0"],"last_affected":[],"package":"katalyst-koi","purl":"pkg:gem/katalyst-koi","source":"GHSA-4cx3-3c38-j9vv"}],"prev":{"headline":"Medplum - Exposure of OAuth client secret via dynamic registration endpoint in self-hosted configurations","id":"CVE-2026-44506"},"products":["koi"],"published":"2026-05-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-14","vendors":["katalyst"]},"summary":"Attackers can reuse admin session cookies after logout to maintain unauthorized access to administrative functions in Katalyst Koi.","url":"https://insights.sbomify.com/CVE-2026-44511/"}