# CVE-2026-44514: Kubetail: Cross-Site WebSocket Hijacking allows attacker to read Kubernetes logs from authenticated users

> Attackers can hijack WebSocket connections to read Kubernetes logs from authenticated users via malicious web pages.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 16 May 2026
- **Also known as:** GHSA-v8j7-hp7c-738f, GO-2026-5656

## What is CVE-2026-44514?

CVE-2026-44514 is a medium-severity vulnerability in github.com/kubetail-org/kubetail/modules/cli, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Kubetail is a real-time logging dashboard for Kubernetes. Prior to 0.14.0, Kubetail's dashboard exposes WebSocket endpoints that did not adequately validate the Origin header on connection upgrade. A malicious web page visited by a user with an active Kubetail session could open a WebSocket to the user's dashboard and read their Kubernetes logs in real time. This is a Cross-Site WebSocket Hijacking (CSWSH) vulnerability and affects both the desktop deployment (default http://localhost:7500) and cluster deployments (typically behind an Ingress with HTTP basic auth). This vulnerability is fixed in 0.14.0.

Weakness: CWE-1385 (Missing Origin Validation in WebSockets)

## Which versions are affected by CVE-2026-44514?

6 open source packages ship an affected version, including github.com/kubetail-org/kubetail/modules/cli and github.com/kubetail-org/kubetail/modules/dashboard.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kubetail-org/kubetail/modules/cli` | Go | All versions | None |
| `github.com/kubetail-org/kubetail/modules/cli` | Go | All versions | 0.16.0 |
| `github.com/kubetail-org/kubetail/modules/cli` | Go | All versions | 0.16.0 |
| `github.com/kubetail-org/kubetail/modules/dashboard` | Go | All versions | None |
| `github.com/kubetail-org/kubetail/modules/dashboard` | Go | All versions | 0.14.0 |
| `github.com/kubetail-org/kubetail/modules/dashboard` | Go | All versions | 0.14.0 |

## How do I fix CVE-2026-44514?

Upgrade github.com/kubetail-org/kubetail/modules/cli to 0.16.0 or later.

## Is CVE-2026-44514 being exploited?

There is no known exploitation of CVE-2026-44514 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44514 and fix it if it is affected.

What it is: CVE-2026-44514 is a medium-severity vulnerability in github.com/kubetail-org/kubetail/modules/cli, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44514 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kubetail-org/kubetail/modules/cli (Go): affected all versions; no fix listed
- github.com/kubetail-org/kubetail/modules/cli (Go): affected all versions; fixed in 0.16.0
- github.com/kubetail-org/kubetail/modules/cli (Go): affected all versions; fixed in 0.16.0
- github.com/kubetail-org/kubetail/modules/dashboard (Go): affected all versions; no fix listed
- github.com/kubetail-org/kubetail/modules/dashboard (Go): affected all versions; fixed in 0.14.0
- github.com/kubetail-org/kubetail/modules/dashboard (Go): affected all versions; fixed in 0.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44514/ (Markdown: https://insights.sbomify.com/CVE-2026-44514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44514
- OSV: https://osv.dev/vulnerability/CVE-2026-44514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44514/
Summaries are generated and may contain mistakes; the official description above is the record.
