# CVE-2026-44515: Nextcloud News: Authenticated blind SSRF via feed URL

> Authenticated attackers can exploit blind SSRF in Nextcloud News to scan internal network services via malicious feed URLs.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-jcfr-rmj6-cpfj

## What is CVE-2026-44515?

CVE-2026-44515 is a low-severity server-side request forgery vulnerability in nextcloud news, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nextcloud News is an RSS/Atom feed reader. Prior to 28.3.0-beta.1, Nextcloud News allows authenticated users to add feeds by providing a feed URL (via the web interface or the API). In affected versions, an authenticated attacker could provide a URL pointing to internal/private IP ranges or localhost, causing the Nextcloud server to perform server-side HTTP requests to attacker-controlled destinations, but not relaying the result. This enables blind SSRF, which can be used to scan or probe internal network services that are reachable from the Nextcloud server. This vulnerability is fixed in 28.3.0-beta.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44515?


## How do I fix CVE-2026-44515?

No fix has been published for CVE-2026-44515 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44515 being exploited?

There is no known exploitation of CVE-2026-44515 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44515 and fix it if it is affected.

What it is: CVE-2026-44515 is a low-severity server-side request forgery vulnerability in nextcloud news, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44515 in the wild and no public exploit code.

Affected product: nextcloud news. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44515/ (Markdown: https://insights.sbomify.com/CVE-2026-44515/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44515
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44515
- OSV: https://osv.dev/vulnerability/CVE-2026-44515

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44515/
Summaries are generated and may contain mistakes; the official description above is the record.
