# CVE-2026-44521: elFinder: SQL Injection MySQL Volume Driver (elFinderVolumeMySQL)

> Authenticated users can inject SQL via crafted file hashes in the MySQL volume driver, leading to data disclosure or denial of service.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-c3gj-q88f-7hqj

## What is CVE-2026-44521?

CVE-2026-44521 is a high-severity SQL injection vulnerability in Studio-42 elFinder, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

elFinder is an open-source file manager for web, written in JavaScript using jQuery UI. Prior to 2.1.68, an authenticated SQL injection vulnerability in the elFinder MySQL volume driver (elFinderVolumeMySQL) allows any logged-in user, including users with read-only access to the affected volume, to inject SQL through a crafted target file hash. Successful exploitation can lead to unauthorized data disclosure and denial of service. This vulnerability only affects installations configured to use the MySQL volume driver. This vulnerability is fixed in 2.1.68.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-44521?

2 open source packages ship an affected version, including studio-42/elfinder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `studio-42/elfinder` | Packagist | All versions | 2.1.68 |
| `studio-42/elfinder` | Packagist | All versions | 2.1.68 |

## How do I fix CVE-2026-44521?

Upgrade studio-42/elfinder to 2.1.68 or later.

## Is CVE-2026-44521 being exploited?

There is no known exploitation of CVE-2026-44521 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44521 and fix it if it is affected.

What it is: CVE-2026-44521 is a high-severity SQL injection vulnerability in Studio-42 elFinder, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44521 in the wild and no public exploit code.

Affected packages and fixed versions:
- studio-42/elfinder (Packagist): affected all versions; fixed in 2.1.68
- studio-42/elfinder (Packagist): affected all versions; fixed in 2.1.68

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44521/ (Markdown: https://insights.sbomify.com/CVE-2026-44521/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44521
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44521
- OSV: https://osv.dev/vulnerability/CVE-2026-44521

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44521/
Summaries are generated and may contain mistakes; the official description above is the record.
