CVE-2026-44541 Fides: DOM-based XSS vulnerability in fides.js via fides_description override

High 7.0 Published Updated

An attacker can execute arbitrary JavaScript in the victim's browser via a DOM-based XSS vulnerability in the fides.js script.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44541?

CVE-2026-44541 is a high-severity cross-site scripting vulnerability in ethyca fides, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Fides is an open-source privacy engineering platform. From version 2.33.0 to before version 2.84.5, there is a DOM-based XSS vulnerability in fides.js via the fides_description override. This issue has been patched in version 2.84.5.

Weakness: CWE-79

Which versions are affected by CVE-2026-44541?

3 open source packages ship an affected version, including ethyca-fides.

PackageAffectedFixed in
ethyca-fides PyPIFrom 2.33.02.84.5
ethyca-fides PyPIFrom 2.33.02.84.5
ethyca-fides PyPIFrom 2.33.02.84.5

How do I fix CVE-2026-44541?

Upgrade ethyca-fides to 2.84.5 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-44541 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44541 exists.

Sources

Also known as GHSA-5qrq-9645-g5g2, PYSEC-2026-2470.

Is CVE-2026-44541 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free