{"answers":{"affected":"3 open source packages ship an affected version, including ethyca-fides.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44541 exists.","fix":"Upgrade ethyca-fides to 2.84.5 or later.","what":"CVE-2026-44541 is a high-severity cross-site scripting vulnerability in ethyca fides, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44541 and fix it if it is affected.\n\nWhat it is: CVE-2026-44541 is a high-severity cross-site scripting vulnerability in ethyca fides, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44541 exists.\n\nAffected packages and fixed versions:\n- ethyca-fides (PyPI): affected from 2.33.0; fixed in 2.84.5\n- ethyca-fides (PyPI): affected from 2.33.0; fixed in 2.84.5\n- ethyca-fides (PyPI): affected from 2.33.0; fixed in 2.84.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44541/ (Markdown: https://insights.sbomify.com/CVE-2026-44541/index.md)","id":"CVE-2026-44541","markdown":"https://insights.sbomify.com/CVE-2026-44541/index.md","name":"CVE-2026-44541","record":{"aliases":["GHSA-5qrq-9645-g5g2","PYSEC-2026-2470"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Privacy engineering platform","requires_auth":"none","summary":"An attacker can execute arbitrary JavaScript in the victim's browser via a DOM-based XSS vulnerability in the fides.js script.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Fides is an open-source privacy engineering platform. From version 2.33.0 to before version 2.84.5, there is a DOM-based XSS vulnerability in fides.js via the fides_description override. This issue has been patched in version 2.84.5.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Fides: DOM-based XSS vulnerability in fides.js via fides_description override","id":"CVE-2026-44541","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"FileBrowser Quantum: Unauthenticated Path Traversal in Public Share Delete Allows Arbitrary File Deletion","id":"CVE-2026-44542"},"packages":[{"ecosystem":"PyPI","fixed":["2.84.5"],"introduced":["2.33.0"],"last_affected":[],"package":"ethyca-fides","purl":null,"source":"GHSA-5qrq-9645-g5g2"},{"ecosystem":"PyPI","fixed":["2.84.5"],"introduced":["2.33.0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"GHSA-5qrq-9645-g5g2"},{"ecosystem":"PyPI","fixed":["2.84.5"],"introduced":["2.33.0"],"last_affected":[],"package":"ethyca-fides","purl":"pkg:pypi/ethyca-fides","source":"PYSEC-2026-2470"}],"prev":{"headline":"Note Mark: JWT Secret Weakness allows Full Account Takeover via token forgery","id":"CVE-2026-44523"},"products":["fides"],"published":"2026-06-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-09","vendors":["ethyca"]},"summary":"An attacker can execute arbitrary JavaScript in the victim's browser via a DOM-based XSS vulnerability in the fides.js script.","url":"https://insights.sbomify.com/CVE-2026-44541/"}