# CVE-2026-44541: Fides: DOM-based XSS vulnerability in fides.js via fides_description override

> An attacker can execute arbitrary JavaScript in the victim's browser via a DOM-based XSS vulnerability in the fides.js script.

- **Severity:** High 7.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2026
- **Updated:** 9 Jun 2026
- **Also known as:** GHSA-5qrq-9645-g5g2, PYSEC-2026-2470

## What is CVE-2026-44541?

CVE-2026-44541 is a high-severity cross-site scripting vulnerability in ethyca fides, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fides is an open-source privacy engineering platform. From version 2.33.0 to before version 2.84.5, there is a DOM-based XSS vulnerability in fides.js via the fides_description override. This issue has been patched in version 2.84.5.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-44541?

3 open source packages ship an affected version, including ethyca-fides.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ethyca-fides` | PyPI | From 2.33.0 | 2.84.5 |
| `ethyca-fides` | PyPI | From 2.33.0 | 2.84.5 |
| `ethyca-fides` | PyPI | From 2.33.0 | 2.84.5 |

## How do I fix CVE-2026-44541?

Upgrade ethyca-fides to 2.84.5 or later.

## Is CVE-2026-44541 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44541 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44541 and fix it if it is affected.

What it is: CVE-2026-44541 is a high-severity cross-site scripting vulnerability in ethyca fides, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44541 exists.

Affected packages and fixed versions:
- ethyca-fides (PyPI): affected from 2.33.0; fixed in 2.84.5
- ethyca-fides (PyPI): affected from 2.33.0; fixed in 2.84.5
- ethyca-fides (PyPI): affected from 2.33.0; fixed in 2.84.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44541/ (Markdown: https://insights.sbomify.com/CVE-2026-44541/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44541
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44541
- OSV: https://osv.dev/vulnerability/CVE-2026-44541

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44541/
Summaries are generated and may contain mistakes; the official description above is the record.
