{"answers":{"affected":"3 open source packages ship an affected version, including daphne. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44545 in the wild and no public exploit code.","fix":"Upgrade daphne to 4.2.2 or later.","what":"CVE-2026-44545 is a medium-severity denial of service vulnerability in djangoproject daphne, published on 3 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44545 and fix it if it is affected.\n\nWhat it is: CVE-2026-44545 is a medium-severity denial of service vulnerability in djangoproject daphne, published on 3 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44545 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- daphne (PyPI): affected all versions; fixed in 4.2.2\n- daphne (PyPI): affected all versions; fixed in 4.2.2\n- daphne (PyPI): affected all versions; fixed in 4.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44545/ (Markdown: https://insights.sbomify.com/CVE-2026-44545/index.md)","id":"CVE-2026-44545","markdown":"https://insights.sbomify.com/CVE-2026-44545/index.md","name":"CVE-2026-44545","record":{"aliases":["DEBIAN-CVE-2026-44545","ECHO-f779-f50f-e49e","GHSA-rrc9-mx66-ffcm","PYSEC-2026-213","UBUNTU-CVE-2026-44545"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Daphne ASGI server","requires_auth":"none","summary":"Unauthenticated attackers can cause denial of service by sending oversized WebSocket messages due to missing size limits in Daphne.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"DSF","cpe":[{"product":"daphne","vendor":"djangoproject"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"daphne before 4.2.2 did not pass maxFramePayloadSize or maxMessagePayloadSize to Autobahn's WebSocketServerFactory. Because Autobahn defaults both values to 0 (unlimited), an unauthenticated remote attacker could send arbitrarily large WebSocket messages or frames, causing excessive memory consumption and a denial of service.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unbounded WebSocket message and frame sizes can cause unauthenticated remote denial of service","id":"CVE-2026-44545","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Header injection via WebSocket upgrade parser differential allows ASGI scope header spoofing","id":"CVE-2026-44546"},"packages":[{"ecosystem":"PyPI","fixed":["4.2.2"],"introduced":["0"],"last_affected":[],"package":"daphne","purl":null,"source":"GHSA-rrc9-mx66-ffcm"},{"ecosystem":"PyPI","fixed":["4.2.2"],"introduced":["0"],"last_affected":[],"package":"daphne","purl":"pkg:pypi/daphne","source":"GHSA-rrc9-mx66-ffcm"},{"ecosystem":"PyPI","fixed":["4.2.2"],"introduced":["0"],"last_affected":[],"package":"daphne","purl":"pkg:pypi/daphne","source":"PYSEC-2026-213"}],"prev":{"headline":"gittuf: Policy can be rolled back to prior valid version","id":"CVE-2026-44544"},"products":["daphne"],"published":"2026-06-03","related":[{"cvss_score":3.7,"headline":"Header injection via WebSocket upgrade parser differential allows ASGI scope header spoofing","id":"CVE-2026-44546","kev_date_added":null,"published":"2026-06-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-03","vendors":["djangoproject"]},"summary":"Unauthenticated attackers can cause denial of service by sending oversized WebSocket messages due to missing size limits in Daphne.","url":"https://insights.sbomify.com/CVE-2026-44545/"}