# CVE-2026-44555: Open WebUI: Base Model Routing Bypasses Access Control via Model Chaining

> Users can bypass access controls to invoke restricted AI models by chaining them to user-created models, exposing sensitive inference capabilities.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-9vvh-qmjx-p4q8, PYSEC-2026-2719

## What is CVE-2026-44555?

CVE-2026-44555 is a high-severity missing authorization vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.9.0, Open WebUI supports model composition via base_model_id: a user-defined model (e.g., "Cheap Assistant") can reference an existing base model (e.g., "gpt-4-turbo-restricted") that provides the actual inference capability. When a user queries the composed model, the access control pipeline verifies the user has access to the composed model but never re-verifies access to the chained base model. Additionally, the model creation and import endpoints accept arbitrary base_model_id values without checking that the caller has access to that base model. Combined, this allows any user with the default model creation permission to create a model that chains to a restricted base model — and then invoke it, causing the server to dispatch the request to the restricted base model using the admin-configured API key. This vulnerability is fixed in 0.9.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-44555?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.9.0 |
| `open-webui` | PyPI | All versions | 0.9.0 |
| `open-webui` | PyPI | All versions | 0.9.0 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-44555?

Upgrade open-webui to 0.9.0 or later.

## Is CVE-2026-44555 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44555 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44555 and fix it if it is affected.

What it is: CVE-2026-44555 is a high-severity missing authorization vulnerability in Openwebui Open Webui, published on 15 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44555 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.9.0
- open-webui (PyPI): affected all versions; fixed in 0.9.0
- open-webui (PyPI): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44555/ (Markdown: https://insights.sbomify.com/CVE-2026-44555/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44555
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44555
- OSV: https://osv.dev/vulnerability/CVE-2026-44555

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44555/
Summaries are generated and may contain mistakes; the official description above is the record.
