# CVE-2026-44567: Open WebUI: Open WebUI Improper Authorization Control

> Attackers can bypass role restrictions to access the application when new sign-ups are enabled, requiring an upgrade to Open WebUI.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 18 May 2026
- **Also known as:** GHSA-4vg5-rp28-gvjf, PYSEC-2026-2703

## What is CVE-2026-44567?

CVE-2026-44567 is a high-severity missing authorization vulnerability in Openwebui Open Webui, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Prior to 0.1.124, the API does not properly validate that the user has an authorized user role of user. By default, when Open WebUI is configured with new sign-ups enabled, the default user role is set to pending. In this configuration, an administrator is required to go into the Admin management panel following a new user registration and reconfigure the user to have a role of either user or admin before that user is able to access the web application. This vulnerability is fixed in 0.1.124.

Weakness: CWE-863 (Incorrect Authorization), CWE-602 (Client-Side Enforcement of Server-Side Security)

## Which versions are affected by CVE-2026-44567?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.1.124 |
| `open-webui` | PyPI | All versions | 0.1.124 |
| `open-webui` | PyPI | All versions | 0.1.124 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-44567?

Upgrade open-webui to 0.1.124 or later.

## Is CVE-2026-44567 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44567 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44567 and fix it if it is affected.

What it is: CVE-2026-44567 is a high-severity missing authorization vulnerability in Openwebui Open Webui, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44567 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.1.124
- open-webui (PyPI): affected all versions; fixed in 0.1.124
- open-webui (PyPI): affected all versions; fixed in 0.1.124

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44567/ (Markdown: https://insights.sbomify.com/CVE-2026-44567/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44567
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44567
- OSV: https://osv.dev/vulnerability/CVE-2026-44567

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44567/
Summaries are generated and may contain mistakes; the official description above is the record.
