# CVE-2026-44572: Next.js: Middleware / Proxy redirects can be cache-poisoned

> Attackers can poison CDN caches via crafted headers, causing denial of service for redirect paths in Next.js applications behind caching proxies.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** CLEANSTART-2026-EY13226, CLEANSTART-2026-TC69199, GHSA-3g8h-86w9-wvmq, MINI-847r-r7jc-8864, MINI-gp28-34hr-7976, MINI-mcx2-cp43-vp45, MINI-w656-vv5x-gm94, ROOT-APP-NPM-CVE-2026-44572

## What is CVE-2026-44572?

CVE-2026-44572 is a low-severity denial of service vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. From 12.2.0 to before 15.5.16 and 16.2.5, an external client could send a x-nextjs-data header on a normal request to a path handled by middleware that returns a redirect. When that happened, the middleware/proxy could treat the request as a data request and replace the standard Location redirect header with the internal x-nextjs-redirect header. Browsers do not follow x-nextjs-redirect, so the response became an unusable redirect for normal clients. If the application was deployed behind a CDN or reverse proxy that caches 3xx responses without varying on this header, a single attacker request could poison the cached redirect response for the affected path. Subsequent visitors could then receive a cached redirect response without a Location header, causing a denial of service for that redirect path until the cache entry expired or was purged. This vulnerability is fixed in 15.5.16 and 16.2.5.

Weakness: CWE-349 (Acceptance of Extraneous Untrusted Data With Trusted Data)

## Which versions are affected by CVE-2026-44572?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 12.2.0 | 15.5.16 |
| `next` | npm | From 12.2.0 | 15.5.16 |
| `next` | npm | From 16.0.0 | 16.2.5 |
| `next` | npm | From 16.0.0 | 16.2.5 |

Products: Vercel Next.js.

## How do I fix CVE-2026-44572?

Upgrade next to a fixed version for your release line: 15.5.16 or 16.2.5.

## Is CVE-2026-44572 being exploited?

There is no known exploitation of CVE-2026-44572 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44572 and fix it if it is affected.

What it is: CVE-2026-44572 is a low-severity denial of service vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44572 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 12.2.0; fixed in 15.5.16
- next (npm): affected from 12.2.0; fixed in 15.5.16
- next (npm): affected from 16.0.0; fixed in 16.2.5
- next (npm): affected from 16.0.0; fixed in 16.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44572/ (Markdown: https://insights.sbomify.com/CVE-2026-44572/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44572
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44572
- OSV: https://osv.dev/vulnerability/CVE-2026-44572

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44572/
Summaries are generated and may contain mistakes; the official description above is the record.
