# CVE-2026-44577: Next.js: Denial of Service in the Image Optimization API

> Attackers can cause out-of-memory denial of service in self-hosted Next.js apps by requesting large local images via the Image Optimization API.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 13 Aug 2026
- **Also known as:** CLEANSTART-2026-OD37037, CLEANSTART-2026-OP77643, GHSA-h64f-5h5j-jqjh, MINI-2g72-w343-q4h6, MINI-f238-fxxw-f73j, MINI-vw58-mh62-f8v5, MINI-wr8r-q2mm-whr8, ROOT-APP-NPM-CVE-2026-44577

## What is CVE-2026-44577?

CVE-2026-44577 is a medium-severity denial of service vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. From 10.0.0 to before 15.5.16 and 16.2.5, when self-hosting Next.js with the default image loader, the Image Optimization API fetches local images entirely into memory without enforcing a maximum size limit. An attacker could cause out-of-memory conditions by requesting large local assets from the /_next/image endpoint that match the images.localPatterns configuration (by default, all patterns are allowed). This vulnerability is fixed in 15.5.16 and 16.2.5.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-44577?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 10.0.0 | 15.5.16 |
| `next` | npm | From 10.0.0 | 15.5.16 |
| `next` | npm | From 16.0.0 | 16.2.5 |
| `next` | npm | From 16.0.0 | 16.2.5 |

Products: Vercel Next.js.

## How do I fix CVE-2026-44577?

Upgrade next to a fixed version for your release line: 15.5.16 or 16.2.5.

## Is CVE-2026-44577 being exploited?

There is no known exploitation of CVE-2026-44577 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44577 and fix it if it is affected.

What it is: CVE-2026-44577 is a medium-severity denial of service vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44577 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 10.0.0; fixed in 15.5.16
- next (npm): affected from 10.0.0; fixed in 15.5.16
- next (npm): affected from 16.0.0; fixed in 16.2.5
- next (npm): affected from 16.0.0; fixed in 16.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44577/ (Markdown: https://insights.sbomify.com/CVE-2026-44577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44577
- OSV: https://osv.dev/vulnerability/CVE-2026-44577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44577/
Summaries are generated and may contain mistakes; the official description above is the record.
