# CVE-2026-44578: Next.js: Server-side request forgery in applications using WebSocket upgrades

> Attackers can exploit WebSocket upgrades in self-hosted Next.js apps to perform server-side request forgery, exposing internal services or cloud metadata.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 13 Aug 2026
- **Also known as:** CLEANSTART-2026-WQ22617, CLEANSTART-2026-WR08487, GHSA-c4j6-fc7j-m34r, MINI-32r3-hxmf-g53g, MINI-3cq8-qx74-cfx9, MINI-p88j-rx68-3gp2, MINI-q45p-fmhw-8pvg, ROOT-APP-NPM-CVE-2026-44578

## What is CVE-2026-44578?

CVE-2026-44578 is a high-severity server-side request forgery vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44578?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 13.4.13 | 15.5.16 |
| `next` | npm | From 13.4.13 | 15.5.16 |
| `next` | npm | From 16.0.0 | 16.2.5 |
| `next` | npm | From 16.0.0 | 16.2.5 |

Products: Vercel Next.js.

## How do I fix CVE-2026-44578?

Upgrade next to a fixed version for your release line: 15.5.16 or 16.2.5.

## Is CVE-2026-44578 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44578 exists.

Public exploit code:

- NextSSRF — CVE-2026-44578 Scanner & Exploit          ║ ║   Next.js WebSocket Upgrade Handler SSRF (github_poc): https://github.com/ynsmroztas/nextssrf
- CVE-2026-44578: Next.js WebSocket Upgrade SSRF — pre-auth credential theft via localhost:80. Lab + exploit + audit. (github_poc): https://github.com/dinosn/CVE-2026-44578
- Nuclei templates for detecting CVE-2026-44578 (Next.js WebSocket Upgrade SSRF) with multi-cloud metadata validation, Next.js fingerprinting, and real-world scanning workflows. Includes references to the original NextSSRF research and exploit tooling. (github_poc): https://github.com/love07oj/nextjs-cve-2026-44578
- CVE-2026-44578 (github_poc): https://github.com/0xredash/CVE-2026-44578
- CVE-2026-44578 PoC (github_poc): https://github.com/lxxexxbxx/CVE-2026-44578
- OOB verifier for GHSA-c4j6-fc7j-m34r / CVE-2026-44578 (Next.js WebSocket-upgrade SSRF) (github_poc): https://github.com/panchocosil/verify-ghsa-c4j6-fc7j-m34r

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)
- [CVE-2026-64649](https://insights.sbomify.com/CVE-2026-64649/): Next.js: Server-Side Request Forgery in Server Actions on Custom Servers (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44578 and fix it if it is affected.

What it is: CVE-2026-44578 is a high-severity server-side request forgery vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44578 exists.

Affected packages and fixed versions:
- next (npm): affected from 13.4.13; fixed in 15.5.16
- next (npm): affected from 13.4.13; fixed in 15.5.16
- next (npm): affected from 16.0.0; fixed in 16.2.5
- next (npm): affected from 16.0.0; fixed in 16.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44578/ (Markdown: https://insights.sbomify.com/CVE-2026-44578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44578
- OSV: https://osv.dev/vulnerability/CVE-2026-44578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44578/
Summaries are generated and may contain mistakes; the official description above is the record.
