# CVE-2026-44579: Next.js: Denial of Service via connection exhaustion in applications using Cache Components

> Attackers can cause denial of service in Next.js apps using Cache Components by exhausting server connections via crafted POST requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 13 Aug 2026
- **Also known as:** CLEANSTART-2026-WQ90566, CLEANSTART-2026-XA53672, GHSA-mg66-mrh9-m8jx, MINI-c8cw-cjr3-4fq3, MINI-qrwp-8pv4-2fr8, MINI-vxmc-cp99-x64h, MINI-whj6-68wj-xvf9, ROOT-APP-NPM-CVE-2026-44579

## What is CVE-2026-44579?

CVE-2026-44579 is a high-severity denial of service vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. From  to before 15.5.16 and 16.2.5, applications using Partial Prerendering through the Cache Components feature can be vulnerable to connection exhaustion through crafted POST requests to a server action. In affected configurations, a malicious request can trigger a request-body handling deadlock that leaves connections open for an extended period, consuming file descriptors and server capacity until legitimate users are denied service. This vulnerability is fixed in 15.5.16 and 16.2.5.

Weakness: CWE-833 (Deadlock), CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-44579?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 15.0.0 | 15.5.16 |
| `next` | npm | From 15.0.0 | 15.5.16 |
| `next` | npm | From 16.0.0 | 16.2.5 |
| `next` | npm | From 16.0.0 | 16.2.5 |

Products: Vercel Next.js.

## How do I fix CVE-2026-44579?

Upgrade next to a fixed version for your release line: 15.5.16 or 16.2.5.

## Is CVE-2026-44579 being exploited?

There is no known exploitation of CVE-2026-44579 in the wild and no public exploit code.

Public exploit code:

- ARCHIVED: FBC v2 consulting website draft. Deprecated. Vulnerable to CVE-2026-44579 (Next.js Cache DoS). (github_poc): https://github.com/iamfarzad/fbcounsulting_v2

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44579 and fix it if it is affected.

What it is: CVE-2026-44579 is a high-severity denial of service vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44579 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 15.0.0; fixed in 15.5.16
- next (npm): affected from 15.0.0; fixed in 15.5.16
- next (npm): affected from 16.0.0; fixed in 16.2.5
- next (npm): affected from 16.0.0; fixed in 16.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44579/ (Markdown: https://insights.sbomify.com/CVE-2026-44579/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44579
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44579
- OSV: https://osv.dev/vulnerability/CVE-2026-44579

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44579/
Summaries are generated and may contain mistakes; the official description above is the record.
