{"answers":{"affected":"4 open source packages ship an affected version, including next. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44580 in the wild and no public exploit code.","fix":"Upgrade next to a fixed version for your release line: 15.5.16 or 16.2.5.","what":"CVE-2026-44580 is a medium-severity cross-site scripting vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44580 and fix it if it is affected.\n\nWhat it is: CVE-2026-44580 is a medium-severity cross-site scripting vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-44580 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- next (npm): affected from 13.0.0; fixed in 15.5.16\n- next (npm): affected from 13.0.0; fixed in 15.5.16\n- next (npm): affected from 16.0.0; fixed in 16.2.5\n- next (npm): affected from 16.0.0; fixed in 16.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44580/ (Markdown: https://insights.sbomify.com/CVE-2026-44580/index.md)","id":"CVE-2026-44580","markdown":"https://insights.sbomify.com/CVE-2026-44580/index.md","name":"CVE-2026-44580","record":{"aliases":["CLEANSTART-2026-SO65050","CLEANSTART-2026-UT46533","GHSA-gx5p-jg67-6x7h","MINI-48p6-4v42-3697","MINI-5qjj-2g2j-7h5x","MINI-gwcj-4v53-358j","MINI-mpxq-5f36-gccf","ROOT-APP-NPM-CVE-2026-44580"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Next.js framework","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in visitors' browsers via untrusted input in beforeInteractive scripts, affecting Next.js applications.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"next.js","vendor":"vercel"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Next.js: Cross-site scripting in beforeInteractive scripts with untrusted input","id":"CVE-2026-44580","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"vercel:next.js","products":["vercel:next.js"],"type":"xss","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"Next.js: Cross-site scripting in App Router applications using CSP nonces","id":"CVE-2026-44581"},"packages":[{"ecosystem":"npm","fixed":["15.5.16"],"introduced":["13.0.0"],"last_affected":[],"package":"next","purl":null,"source":"GHSA-gx5p-jg67-6x7h"},{"ecosystem":"npm","fixed":["15.5.16"],"introduced":["13.0.0"],"last_affected":[],"package":"next","purl":"pkg:npm/next","source":"GHSA-gx5p-jg67-6x7h"},{"ecosystem":"npm","fixed":["16.2.5"],"introduced":["16.0.0"],"last_affected":[],"package":"next","purl":null,"source":"GHSA-gx5p-jg67-6x7h"},{"ecosystem":"npm","fixed":["16.2.5"],"introduced":["16.0.0"],"last_affected":[],"package":"next","purl":"pkg:npm/next","source":"GHSA-gx5p-jg67-6x7h"}],"prev":{"headline":"Next.js: Denial of Service via connection exhaustion in applications using Cache Components","id":"CVE-2026-44579"},"products":["next.js"],"published":"2026-05-13","related":[{"cvss_score":9.1,"headline":"Authorization Bypass in Next.js Middleware","id":"CVE-2025-29927","kev_date_added":null,"published":"2025-03-21"},{"cvss_score":8.6,"headline":"Next.js: Server-side request forgery in applications using WebSocket upgrades","id":"CVE-2026-44578","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in Image Optimization","id":"CVE-2026-94483","kev_date_added":null,"published":"2026-10-02"},{"cvss_score":8.3,"headline":"Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale","id":"CVE-2026-64642","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname","id":"CVE-2026-64645","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in Server Actions on Custom Servers","id":"CVE-2026-64649","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.2,"headline":"Next.js: Denial of Service in App Router using Server Actions","id":"CVE-2026-64641","kev_date_added":null,"published":"2026-07-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-13","vendors":["vercel"]},"summary":"Attackers can execute arbitrary JavaScript in visitors' browsers via untrusted input in beforeInteractive scripts, affecting Next.js applications.","url":"https://insights.sbomify.com/CVE-2026-44580/"}