CVE-2026-44581 Next.js: Cross-site scripting in App Router applications using CSP nonces

Medium 4.7 Published Updated

Attackers can poison cached responses to execute scripts in Next.js App Router applications using CSP nonces, affecting web developers and site visitors.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-44581?

CVE-2026-44581 is a medium-severity cross-site scripting vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.

Weakness: CWE-79

Which versions are affected by CVE-2026-44581?

4 open source packages ship an affected version, including next. It affects 1 product.

PackageAffectedFixed in
next npmFrom 13.4.015.5.16
next npmFrom 13.4.015.5.16
next npmFrom 16.0.016.2.5
next npmFrom 16.0.016.2.5

Products include Vercel Next.js.

How do I fix CVE-2026-44581?

Upgrade next to a fixed version for your release line: 15.5.16 or 16.2.5.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-44581 being exploited?

There is no known exploitation of CVE-2026-44581 in the wild and no public exploit code.

All Vercel Next.js vulnerabilities

Sources

Also known as CLEANSTART-2026-UW85548, CLEANSTART-2026-WK40979, GHSA-ffhc-5mcf-pf4q, MINI-95vg-fhjh-rqfc, MINI-mhwm-g87f-3xj3, MINI-v5fq-qjgx-x55x and 2 more.

Is CVE-2026-44581 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free