# CVE-2026-44582: Next.js: Cache poisoning via collisions in React Server Component cache-busting

> Attackers can poison shared caches in Next.js deployments, causing users to receive incorrect response variants for specific URLs.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** CLEANSTART-2026-AV98689, CLEANSTART-2026-MX70977, GHSA-vfv6-92ff-j949, MINI-3qj5-8pw8-5pqg, MINI-frw4-pg6m-w298, MINI-rc89-mjhp-gvj3, MINI-xhf5-573r-9v66, ROOT-APP-NPM-CVE-2026-44582

## What is CVE-2026-44582?

CVE-2026-44582 is a low-severity vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework for building full-stack web applications. From 13.4.6 to before 15.5.16 and 16.2.5, React Server Component responses can be vulnerable to cache poisoning in deployments that rely on shared caches with insufficient response partitioning. In affected conditions, collisions in the _rsc cache-busting value can allow an attacker to poison cache entries so users receive the wrong response variant for a given URL. This vulnerability is fixed in 15.5.16 and 16.2.5.

Weakness: CWE-328 (Use of Weak Hash)

## Which versions are affected by CVE-2026-44582?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 13.4.6 | 15.5.16 |
| `next` | npm | From 13.4.6 | 15.5.16 |
| `next` | npm | From 16.0.0 | 16.2.5 |
| `next` | npm | From 16.0.0 | 16.2.5 |

Products: Vercel Next.js.

## How do I fix CVE-2026-44582?

Upgrade next to a fixed version for your release line: 15.5.16 or 16.2.5.

## Is CVE-2026-44582 being exploited?

There is no known exploitation of CVE-2026-44582 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44582 and fix it if it is affected.

What it is: CVE-2026-44582 is a low-severity vulnerability in Vercel Next.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44582 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 13.4.6; fixed in 15.5.16
- next (npm): affected from 13.4.6; fixed in 15.5.16
- next (npm): affected from 16.0.0; fixed in 16.2.5
- next (npm): affected from 16.0.0; fixed in 16.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44582/ (Markdown: https://insights.sbomify.com/CVE-2026-44582/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44582
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44582
- OSV: https://osv.dev/vulnerability/CVE-2026-44582

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44582/
Summaries are generated and may contain mistakes; the official description above is the record.
