{"answers":{"affected":"2 open source packages ship an affected version, including paymenter/paymenter.","exploited":"There is no known exploitation of CVE-2026-44583 in the wild and no public exploit code.","fix":"Upgrade paymenter/paymenter to 1.5.0 or later.","what":"CVE-2026-44583 is a medium-severity server-side request forgery vulnerability in Paymenter, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44583 and fix it if it is affected.\n\nWhat it is: CVE-2026-44583 is a medium-severity server-side request forgery vulnerability in Paymenter, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44583 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44583/ (Markdown: https://insights.sbomify.com/CVE-2026-44583/index.md)","id":"CVE-2026-44583","markdown":"https://insights.sbomify.com/CVE-2026-44583/index.md","name":"CVE-2026-44583","record":{"aliases":["GHSA-7wwh-xcc3-9fcg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Paymenter webshop","requires_auth":"none","summary":"Unauthenticated attackers can trigger server-side HTTP requests to arbitrary internal or external endpoints via the PayPal webhook header, enabling network probing and potential data exfiltration.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the PayPal webhook endpoint /extensions/paypal/webhook processes the PAYPAL-CERT-URL HTTP header without validation, allowing attackers to control server-side HTTP request destinations. This value is passed directly into a server-side HTTP request via file_get_contents, allowing attackers to control the destination of the request. No allowlist, validation, or signature verification is applied to the header before usage. As a result, the application can be coerced into performing HTTP requests to attacker-controlled or internal network destinations. This vulnerability allows remote unauthenticated attackers to induce server-side HTTP GET requests to arbitrary external or internal endpoints. Depending on network configuration, this may lead to: blind SSRF to external attacker-controlled systems, and potential access to internal network services No direct response data is returned to the attacker (blind SSRF), but the issue may still enable sensitive network probing or data exfiltration via side channels. This issue has been fixed in version 1.5.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Paymenter: Blind Unauthenticated SSRF on the Paypal gateway module","id":"CVE-2026-44583","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Paymenter doesn't reset email verification status after email change","id":"CVE-2026-44584"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":null,"source":"GHSA-7wwh-xcc3-9fcg"},{"ecosystem":"Packagist","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":"pkg:composer/paymenter/paymenter","source":"GHSA-7wwh-xcc3-9fcg"}],"prev":{"headline":"Next.js: Cache poisoning via collisions in React Server Component cache-busting","id":"CVE-2026-44582"},"products":["Paymenter"],"published":"2026-07-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-21","vendors":["Paymenter"]},"summary":"Unauthenticated attackers can trigger server-side HTTP requests to arbitrary internal or external endpoints via the PayPal webhook header, enabling network probing and potential data exfiltration.","url":"https://insights.sbomify.com/CVE-2026-44583/"}