# CVE-2026-44583: Paymenter: Blind Unauthenticated SSRF on the Paypal gateway module

> Unauthenticated attackers can trigger server-side HTTP requests to arbitrary internal or external endpoints via the PayPal webhook header, enabling network probing and potential data exfiltration.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** GHSA-7wwh-xcc3-9fcg

## What is CVE-2026-44583?

CVE-2026-44583 is a medium-severity server-side request forgery vulnerability in Paymenter, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the PayPal webhook endpoint /extensions/paypal/webhook processes the PAYPAL-CERT-URL HTTP header without validation, allowing attackers to control server-side HTTP request destinations. This value is passed directly into a server-side HTTP request via file_get_contents, allowing attackers to control the destination of the request. No allowlist, validation, or signature verification is applied to the header before usage. As a result, the application can be coerced into performing HTTP requests to attacker-controlled or internal network destinations. This vulnerability allows remote unauthenticated attackers to induce server-side HTTP GET requests to arbitrary external or internal endpoints. Depending on network configuration, this may lead to: blind SSRF to external attacker-controlled systems, and potential access to internal network services No direct response data is returned to the attacker (blind SSRF), but the issue may still enable sensitive network probing or data exfiltration via side channels. This issue has been fixed in version 1.5.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44583?

2 open source packages ship an affected version, including paymenter/paymenter.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paymenter/paymenter` | Packagist | All versions | 1.5.0 |
| `paymenter/paymenter` | Packagist | All versions | 1.5.0 |

## How do I fix CVE-2026-44583?

Upgrade paymenter/paymenter to 1.5.0 or later.

## Is CVE-2026-44583 being exploited?

There is no known exploitation of CVE-2026-44583 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44583 and fix it if it is affected.

What it is: CVE-2026-44583 is a medium-severity server-side request forgery vulnerability in Paymenter, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44583 in the wild and no public exploit code.

Affected packages and fixed versions:
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44583/ (Markdown: https://insights.sbomify.com/CVE-2026-44583/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44583
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44583
- OSV: https://osv.dev/vulnerability/CVE-2026-44583

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44583/
Summaries are generated and may contain mistakes; the official description above is the record.
