{"answers":{"affected":"2 open source packages ship an affected version, including paymenter/paymenter.","exploited":"There is no known exploitation of CVE-2026-44584 in the wild and no public exploit code.","fix":"Upgrade paymenter/paymenter to 1.5.0 or later.","what":"CVE-2026-44584 is a medium-severity vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44584 and fix it if it is affected.\n\nWhat it is: CVE-2026-44584 is a medium-severity vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44584 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44584/ (Markdown: https://insights.sbomify.com/CVE-2026-44584/index.md)","id":"CVE-2026-44584","markdown":"https://insights.sbomify.com/CVE-2026-44584/index.md","name":"CVE-2026-44584","record":{"aliases":["GHSA-rv89-wch8-c574"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Paymenter webshop","requires_auth":"low_privilege","summary":"Attackers can bypass email verification checks by changing their email address without resetting the verified status, allowing abuse of features gated behind verification.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the email update functionality fails to invalidate the existing verification state when a user changes their email address, allowing a verified account to retain its verified status after switching to an unverified or unowned email address. When a user updated their email address, the system did not reset or revalidate the associated email verification status. As a result, the verification column remained set to “true” even after the email address was changed. Exploitation could potentially result in: misrepresentation of email ownership, bypass of verification-based trust assumptions, and abuse of features gated behind verified status. No direct unauthorized access to other users accounts or data is possible through this issue alone. This issue has been fixed in version 1.5.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Paymenter doesn't reset email verification status after email change","id":"CVE-2026-44584","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"business_logic","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Paymenter: Broken object level authorization via service reference manipulation on ticket creation","id":"CVE-2026-44585"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":null,"source":"GHSA-rv89-wch8-c574"},{"ecosystem":"Packagist","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":"pkg:composer/paymenter/paymenter","source":"GHSA-rv89-wch8-c574"}],"prev":{"headline":"Paymenter: Blind Unauthenticated SSRF on the Paypal gateway module","id":"CVE-2026-44583"},"products":["Paymenter"],"published":"2026-07-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-20","vendors":["Paymenter"]},"summary":"Attackers can bypass email verification checks by changing their email address without resetting the verified status, allowing abuse of features gated behind verification.","url":"https://insights.sbomify.com/CVE-2026-44584/"}