# CVE-2026-44584: Paymenter doesn't reset email verification status after email change

> Attackers can bypass email verification checks by changing their email address without resetting the verified status, allowing abuse of features gated behind verification.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-rv89-wch8-c574

## What is CVE-2026-44584?

CVE-2026-44584 is a medium-severity vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the email update functionality fails to invalidate the existing verification state when a user changes their email address, allowing a verified account to retain its verified status after switching to an unverified or unowned email address. When a user updated their email address, the system did not reset or revalidate the associated email verification status. As a result, the verification column remained set to “true” even after the email address was changed. Exploitation could potentially result in: misrepresentation of email ownership, bypass of verification-based trust assumptions, and abuse of features gated behind verified status. No direct unauthorized access to other users accounts or data is possible through this issue alone. This issue has been fixed in version 1.5.0.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-44584?

2 open source packages ship an affected version, including paymenter/paymenter.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paymenter/paymenter` | Packagist | All versions | 1.5.0 |
| `paymenter/paymenter` | Packagist | All versions | 1.5.0 |

## How do I fix CVE-2026-44584?

Upgrade paymenter/paymenter to 1.5.0 or later.

## Is CVE-2026-44584 being exploited?

There is no known exploitation of CVE-2026-44584 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44584 and fix it if it is affected.

What it is: CVE-2026-44584 is a medium-severity vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44584 in the wild and no public exploit code.

Affected packages and fixed versions:
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44584/ (Markdown: https://insights.sbomify.com/CVE-2026-44584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44584
- OSV: https://osv.dev/vulnerability/CVE-2026-44584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44584/
Summaries are generated and may contain mistakes; the official description above is the record.
