{"answers":{"affected":"2 open source packages ship an affected version, including paymenter/paymenter.","exploited":"There is no known exploitation of CVE-2026-44585 in the wild and no public exploit code.","fix":"Upgrade paymenter/paymenter to 1.5.0 or later.","what":"CVE-2026-44585 is a medium-severity missing authorization vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44585 and fix it if it is affected.\n\nWhat it is: CVE-2026-44585 is a medium-severity missing authorization vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44585 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0\n- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44585/ (Markdown: https://insights.sbomify.com/CVE-2026-44585/index.md)","id":"CVE-2026-44585","markdown":"https://insights.sbomify.com/CVE-2026-44585/index.md","name":"CVE-2026-44585","record":{"aliases":["GHSA-x93q-x9pc-w5hw"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","other"],"network_reachable":"yes","non_default_config":false,"product_category":"Paymenter webshop","requires_auth":"low_privilege","summary":"Authenticated users can create support tickets referencing other users' services by manipulating service IDs, potentially exposing service details to support staff.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the ticket creation endpoint accepts a user-supplied service identifier without enforcing ownership validation, allowing authenticated users to create support tickets referencing services belonging to other accounts by modifying the service ID in the request. An attacker could modify the service ID value in the client-side request and successfully create a ticket associated with another user's service.\nThe vulnerability requires authentication and does not provide direct access to service contents or customer data. However, referenced service information could become visible to support personnel handling the ticket. Successful exploitation could allow an authenticated user to: create support tickets referencing services belonging to other users, potentially cause support staff to interact with or review unrelated customer services. The vulnerability did not allow direct access to another user's service, modification of another user's service or retrieval of confidential service data through the vulnerable endpoint itself. This issue has been fixed in version 1.5.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Paymenter: Broken object level authorization via service reference manipulation on ticket creation","id":"CVE-2026-44585","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"SiYuan: Bazaar marketplace renders unescaped package author metadata, allowing XSS and Electron code execution","id":"CVE-2026-44586"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":null,"source":"GHSA-x93q-x9pc-w5hw"},{"ecosystem":"Packagist","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"paymenter/paymenter","purl":"pkg:composer/paymenter/paymenter","source":"GHSA-x93q-x9pc-w5hw"}],"prev":{"headline":"Paymenter doesn't reset email verification status after email change","id":"CVE-2026-44584"},"products":["Paymenter"],"published":"2026-07-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-21","vendors":["Paymenter"]},"summary":"Authenticated users can create support tickets referencing other users' services by manipulating service IDs, potentially exposing service details to support staff.","url":"https://insights.sbomify.com/CVE-2026-44585/"}