# CVE-2026-44585: Paymenter: Broken object level authorization via service reference manipulation on ticket creation

> Authenticated users can create support tickets referencing other users' services by manipulating service IDs, potentially exposing service details to support staff.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** GHSA-x93q-x9pc-w5hw

## What is CVE-2026-44585?

CVE-2026-44585 is a medium-severity missing authorization vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the ticket creation endpoint accepts a user-supplied service identifier without enforcing ownership validation, allowing authenticated users to create support tickets referencing services belonging to other accounts by modifying the service ID in the request. An attacker could modify the service ID value in the client-side request and successfully create a ticket associated with another user's service.
The vulnerability requires authentication and does not provide direct access to service contents or customer data. However, referenced service information could become visible to support personnel handling the ticket. Successful exploitation could allow an authenticated user to: create support tickets referencing services belonging to other users, potentially cause support staff to interact with or review unrelated customer services. The vulnerability did not allow direct access to another user's service, modification of another user's service or retrieval of confidential service data through the vulnerable endpoint itself. This issue has been fixed in version 1.5.0.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-44585?

2 open source packages ship an affected version, including paymenter/paymenter.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paymenter/paymenter` | Packagist | All versions | 1.5.0 |
| `paymenter/paymenter` | Packagist | All versions | 1.5.0 |

## How do I fix CVE-2026-44585?

Upgrade paymenter/paymenter to 1.5.0 or later.

## Is CVE-2026-44585 being exploited?

There is no known exploitation of CVE-2026-44585 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44585 and fix it if it is affected.

What it is: CVE-2026-44585 is a medium-severity missing authorization vulnerability in Paymenter, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44585 in the wild and no public exploit code.

Affected packages and fixed versions:
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0
- paymenter/paymenter (Packagist): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44585/ (Markdown: https://insights.sbomify.com/CVE-2026-44585/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44585
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44585
- OSV: https://osv.dev/vulnerability/CVE-2026-44585

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44585/
Summaries are generated and may contain mistakes; the official description above is the record.
