CVE-2026-44587 CarrierWave has a denylisted_content_type bypass via Unescaped Regex Metacharacters
Attackers can bypass content type denylists to upload malicious SVG files, leading to stored XSS in applications using CarrierWave.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-44587?
CVE-2026-44587 is a medium-severity vulnerability in carrierwaveuploader carrierwave, published on 16 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
CarrierWave is a framework to upload files from Ruby applications. In versions prior to 2.2.7 and 3.1.3, the content_type_denylist check fails to escape regex metacharacters in string entries, causing the denylist to silently not match the content types it is intended to block. In lib/carrierwave/uploader/content_type_denylist.rb:57, denylist entries are interpolated directly into a regex without Regexp.quote or anchoring, so an entry such as image/svg+xml becomes the pattern /image\/svg+xml/, in which + is treated as a quantifier rather than a literal character and therefore never matches the real MIME type image/svg+xml. This is inconsistent with the allowlist implementation, which correctly applies both Regexp.quote and a \A anchor. Other content types containing regex metacharacters, such as application/xhtml+xml, are affected as well. As a result, any application that relies on content_type_denylist to block image/svg+xml, most commonly to prevent stored XSS, is silently unprotected. An attacker can upload an SVG file containing arbitrary JavaScript; if the application serves that SVG inline from its own origin, the script executes in the victim's browser, resulting in stored XSS. This issue has been fixed in versions 2.2.7 and 3.1.3.
Which versions are affected by CVE-2026-44587?
4 open source packages ship an affected version, including carrierwave. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
carrierwave RubyGems | All versions | 2.2.7 |
carrierwave RubyGems | All versions | 2.2.7 |
carrierwave RubyGems | From 3.0.0.beta | 3.1.3 |
carrierwave RubyGems | From 3.0.0.beta | 3.1.3 |
Products include Carrierwave Project Carrierwave.
How do I fix CVE-2026-44587?
Upgrade carrierwave to a fixed version for your release line: 2.2.7 or 3.1.3.
Is CVE-2026-44587 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44587 exists.
Other vulnerabilities in carrierwaveuploader carrierwave
- CVE-2021-21305 Code Injection vulnerability in CarrierWave
- CVE-2024-29034 CarrierWave's Content-Type allowlist bypass vulnerability which possibly leads to XSS remained
- CVE-2023-49090 CarrierWave has a content-type allowlist bypass vulnerability, possibly leading to XSS
- CVE-2021-21288 Server-side request forgery in CarrierWave
Sources
Also known as DEBIAN-CVE-2026-44587, GHSA-7g26-2qgj-chfg, UBUNTU-CVE-2026-44587.