# CVE-2026-44587: CarrierWave has a denylisted_content_type bypass via Unescaped Regex Metacharacters

> Attackers can bypass content type denylists to upload malicious SVG files, leading to stored XSS in applications using CarrierWave.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jun 2026
- **Updated:** 17 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-44587, GHSA-7g26-2qgj-chfg, UBUNTU-CVE-2026-44587

## What is CVE-2026-44587?

CVE-2026-44587 is a medium-severity vulnerability in carrierwaveuploader carrierwave, published on 16 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CarrierWave is a framework to upload files from Ruby applications. In versions prior to 2.2.7 and 3.1.3, the content_type_denylist check fails to escape regex metacharacters in string entries, causing the denylist to silently not match the content types it is intended to block. In lib/carrierwave/uploader/content_type_denylist.rb:57, denylist entries are interpolated directly into a regex without Regexp.quote or anchoring, so an entry such as image/svg+xml becomes the pattern /image\/svg+xml/, in which + is treated as a quantifier rather than a literal character and therefore never matches the real MIME type image/svg+xml. This is inconsistent with the allowlist implementation, which correctly applies both Regexp.quote and a \A anchor. Other content types containing regex metacharacters, such as application/xhtml+xml, are affected as well. As a result, any application that relies on content_type_denylist to block image/svg+xml, most commonly to prevent stored XSS, is silently unprotected. An attacker can upload an SVG file containing arbitrary JavaScript; if the application serves that SVG inline from its own origin, the script executes in the victim's browser, resulting in stored XSS. This issue has been fixed in versions 2.2.7 and 3.1.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-625 (Permissive Regular Expression), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-44587?

4 open source packages ship an affected version, including carrierwave. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `carrierwave` | RubyGems | All versions | 2.2.7 |
| `carrierwave` | RubyGems | All versions | 2.2.7 |
| `carrierwave` | RubyGems | From 3.0.0.beta | 3.1.3 |
| `carrierwave` | RubyGems | From 3.0.0.beta | 3.1.3 |

Products: Carrierwave Project Carrierwave.

## How do I fix CVE-2026-44587?

Upgrade carrierwave to a fixed version for your release line: 2.2.7 or 3.1.3.

## Is CVE-2026-44587 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44587 exists.

## Other vulnerabilities in carrierwaveuploader carrierwave

- [CVE-2021-21305](https://insights.sbomify.com/CVE-2021-21305/): Code Injection vulnerability in CarrierWave (high 7.4)
- [CVE-2024-29034](https://insights.sbomify.com/CVE-2024-29034/): CarrierWave's Content-Type allowlist bypass vulnerability which possibly leads to XSS remained (medium 6.8)
- [CVE-2023-49090](https://insights.sbomify.com/CVE-2023-49090/): CarrierWave has a content-type allowlist bypass vulnerability, possibly leading to XSS (medium 6.8)
- [CVE-2021-21288](https://insights.sbomify.com/CVE-2021-21288/): Server-side request forgery in CarrierWave (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44587 and fix it if it is affected.

What it is: CVE-2026-44587 is a medium-severity vulnerability in carrierwaveuploader carrierwave, published on 16 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44587 exists.

Affected packages and fixed versions:
- carrierwave (RubyGems): affected all versions; fixed in 2.2.7
- carrierwave (RubyGems): affected all versions; fixed in 2.2.7
- carrierwave (RubyGems): affected from 3.0.0.beta; fixed in 3.1.3
- carrierwave (RubyGems): affected from 3.0.0.beta; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44587/ (Markdown: https://insights.sbomify.com/CVE-2026-44587/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44587
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44587
- OSV: https://osv.dev/vulnerability/CVE-2026-44587

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44587/
Summaries are generated and may contain mistakes; the official description above is the record.
