# CVE-2026-44595: Yamcs: Unauthorized user enumeration via IAM API endpoints

> Authenticated users can enumerate all system accounts and group memberships due to missing privilege checks in Yamcs IAM API endpoints.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 18 Jul 2026
- **Also known as:** GHSA-p2rj-mrmc-9w29

## What is CVE-2026-44595?

CVE-2026-44595 is a medium-severity missing authorization vulnerability in yamcs, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Yamcs is a mission control framework. Prior to 5.12.7, the IAM API endpoints listUsers, getUser, listGroups, and getGroup in yamcs-core did not enforce the required SystemPrivilege.ControlAccess check in yamcs-core/src/main/java/org/yamcs/http/api/IamApi.java, so any authenticated user, even one with low or no privileges, could enumerate all user accounts in the system including their usernames, superuser status, and group memberships. This issue is fixed in versions 5.12.7 and 5.13.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-44595?

2 open source packages ship an affected version, including org.yamcs:yamcs-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.7 |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.7 |

Products: Spaceapplications Yamcs.

## How do I fix CVE-2026-44595?

Upgrade org.yamcs:yamcs-core to 5.12.7 or later.

## Is CVE-2026-44595 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44595 exists.

Public exploit code:

- # CVE-2026-44595 YAMCS Unauthorized User Enumeration via IAM API  (github_poc): https://github.com/ex-cal1bur/CVE-2026-44595
- YAMCS yamcs-core  5.12.7 - User Enumeration (exploitdb)

## Other vulnerabilities in yamcs

- [CVE-2026-46562](https://insights.sbomify.com/CVE-2026-46562/): Yamcs: Remote Code Execution via Mission Database algorithm override (critical 9.8)
- [CVE-2026-44632](https://insights.sbomify.com/CVE-2026-44632/): Yamcs: Server-Side Code Injection (RCE) via Janino Expression Engine in `JavaExprAlgorithmExecutionFactory` (critical 9.1)
- [CVE-2026-46621](https://insights.sbomify.com/CVE-2026-46621/): Yamcs: Authenticated Remote Code Execution (RCE) via Jython Algorithm Code Injection (critical 9.1)
- [CVE-2023-45278](https://insights.sbomify.com/CVE-2023-45278/): Yamcs API Directory Traversal vulnerability (critical 9.1)
- [CVE-2023-45277](https://insights.sbomify.com/CVE-2023-45277/): Yamcs Path Traversal vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44595 and fix it if it is affected.

What it is: CVE-2026-44595 is a medium-severity missing authorization vulnerability in yamcs, published on 16 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44595 exists.

Affected packages and fixed versions:
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.7
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44595/ (Markdown: https://insights.sbomify.com/CVE-2026-44595/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44595
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44595
- OSV: https://osv.dev/vulnerability/CVE-2026-44595

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44595/
Summaries are generated and may contain mistakes; the official description above is the record.
