CVE-2026-44596 Yamcs: No Rate Limiting on Authentication Endpoint

Medium 6.5 Published Updated

An unauthenticated attacker can brute-force user passwords due to missing rate limiting on the authentication endpoint, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44596?

CVE-2026-44596 is a medium-severity vulnerability in yamcs, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Yamcs is a mission control framework. Prior to 5.12.7, the authentication endpoint POST /auth/token in yamcs-core, handled by yamcs-core/src/main/java/org/yamcs/http/auth/AuthHandler.java, lacked any rate limiting, account lockout, or failed-attempt throttling, so an unauthenticated remote attacker could perform unlimited password-guessing attempts against any user account, significantly increasing the risk of successful brute-force attacks. This issue is fixed in versions 5.12.7 and 5.13.0.

Weakness: CWE-307

Which versions are affected by CVE-2026-44596?

2 open source packages ship an affected version, including org.yamcs:yamcs-core. It affects 1 product.

PackageAffectedFixed in
org.yamcs:yamcs-core MavenAll versions5.12.7
org.yamcs:yamcs-core MavenAll versions5.12.7

Products include Spaceapplications Yamcs.

How do I fix CVE-2026-44596?

Upgrade org.yamcs:yamcs-core to 5.12.7 or later.

Is CVE-2026-44596 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44596 exists.

Public exploit code: 1 Exploit-DB entry and 1 proofs of concept on GitHub.

Sources

Also known as GHSA-w5r6-mcgq-7pq4.

Is CVE-2026-44596 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free