# CVE-2026-44596: Yamcs: No Rate Limiting on Authentication Endpoint

> An unauthenticated attacker can brute-force user passwords due to missing rate limiting on the authentication endpoint, potentially leading to account takeover.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2026
- **Updated:** 17 Jul 2026
- **Also known as:** GHSA-w5r6-mcgq-7pq4

## What is CVE-2026-44596?

CVE-2026-44596 is a medium-severity vulnerability in yamcs, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Yamcs is a mission control framework. Prior to 5.12.7, the authentication endpoint POST /auth/token in yamcs-core, handled by yamcs-core/src/main/java/org/yamcs/http/auth/AuthHandler.java, lacked any rate limiting, account lockout, or failed-attempt throttling, so an unauthenticated remote attacker could perform unlimited password-guessing attempts against any user account, significantly increasing the risk of successful brute-force attacks. This issue is fixed in versions 5.12.7 and 5.13.0.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-44596?

2 open source packages ship an affected version, including org.yamcs:yamcs-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.7 |
| `org.yamcs:yamcs-core` | Maven | All versions | 5.12.7 |

Products: Spaceapplications Yamcs.

## How do I fix CVE-2026-44596?

Upgrade org.yamcs:yamcs-core to 5.12.7 or later.

## Is CVE-2026-44596 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44596 exists.

Public exploit code:

- YAMCS yamcs-core < 5.12.7 lacks rate limiting on POST /auth/token. An unauthenticated attacker can perform unlimited brute-force attempts against any account. Never returns HTTP 429. Fixed in 5.12.7. (github_poc): https://github.com/ex-cal1bur/CVE-2026-44596
- YAMCS yamcs-core  5.12.7 - No Rate Limiting (exploitdb)

## Other vulnerabilities in yamcs

- [CVE-2026-46562](https://insights.sbomify.com/CVE-2026-46562/): Yamcs: Remote Code Execution via Mission Database algorithm override (critical 9.8)
- [CVE-2026-44632](https://insights.sbomify.com/CVE-2026-44632/): Yamcs: Server-Side Code Injection (RCE) via Janino Expression Engine in `JavaExprAlgorithmExecutionFactory` (critical 9.1)
- [CVE-2026-46621](https://insights.sbomify.com/CVE-2026-46621/): Yamcs: Authenticated Remote Code Execution (RCE) via Jython Algorithm Code Injection (critical 9.1)
- [CVE-2023-45278](https://insights.sbomify.com/CVE-2023-45278/): Yamcs API Directory Traversal vulnerability (critical 9.1)
- [CVE-2023-45277](https://insights.sbomify.com/CVE-2023-45277/): Yamcs Path Traversal vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44596 and fix it if it is affected.

What it is: CVE-2026-44596 is a medium-severity vulnerability in yamcs, published on 16 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44596 exists.

Affected packages and fixed versions:
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.7
- org.yamcs:yamcs-core (Maven): affected all versions; fixed in 5.12.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44596/ (Markdown: https://insights.sbomify.com/CVE-2026-44596/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44596
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44596
- OSV: https://osv.dev/vulnerability/CVE-2026-44596

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44596/
Summaries are generated and may contain mistakes; the official description above is the record.
