# CVE-2026-44616: Apache Zeppelin: LDAP injection in ActiveDirectoryGroupRealm filter construction

> Authenticated attackers can inject LDAP filters in Apache Zeppelin to expose directory information via the user-search endpoint.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-8cjf-mhhj-2c5p

## What is CVE-2026-44616?

CVE-2026-44616 is a medium-severity vulnerability in Apache Zeppelin, published on 30 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

LDAP injection vulnerability in Apache Zeppelin. ActiveDirectoryGroupRealm constructed LDAP search filters without escaping user-controlled input, allowing an authenticated attacker to inject LDAP filter syntax through the user-search endpoint                   and potentially expose directory information. The role-lookup path was also affected after successful LDAP authentication. This issue affects Apache Zeppelin versions 0.6.0 through 0.12.0. Users are recommended to upgrade to version 0.12.1, which                   fixes this issue.

Weakness: CWE-90 (Improper Neutralization of Special Elements used in an LDAP Query)

## Which versions are affected by CVE-2026-44616?

It affects 1 product.


Products: Apache Zeppelin.

## How do I fix CVE-2026-44616?

No fix has been published for CVE-2026-44616 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44616 being exploited?

There is no known exploitation of CVE-2026-44616 in the wild and no public exploit code.

## Other vulnerabilities in Apache Zeppelin

- [CVE-2024-31864](https://insights.sbomify.com/CVE-2024-31864/): Apache Zeppelin: Remote code execution by adding malicious JDBC connection string (critical 9.8)
- [CVE-2024-31866](https://insights.sbomify.com/CVE-2024-31866/): Apache Zeppelin: Interpreter download command does not escape malicious code injection (critical 9.8)
- [CVE-2019-10095](https://insights.sbomify.com/CVE-2019-10095/): bash command injection in spark interpreter (critical 9.8)
- [CVE-2018-1317](https://insights.sbomify.com/CVE-2018-1317/): Improper Authentication in Apache Zeppelin (high 8.8)
- [CVE-2017-12619](https://insights.sbomify.com/CVE-2017-12619/): Session Fixation in Apache Zeppelin (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44616 and fix it if it is affected.

What it is: CVE-2026-44616 is a medium-severity vulnerability in Apache Zeppelin, published on 30 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44616 in the wild and no public exploit code.

Affected product: Apache Zeppelin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44616/ (Markdown: https://insights.sbomify.com/CVE-2026-44616/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44616
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44616
- OSV: https://osv.dev/vulnerability/CVE-2026-44616

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44616/
Summaries are generated and may contain mistakes; the official description above is the record.
