CVE-2026-44631 Apache HTTP Server: Heap Underflow in `ap_regname` via Signed Char Overflow

Critical 9.8 Published Updated

A heap underflow in Apache HTTP Server allows attackers to cause a denial of service via crafted regular expressions in the configuration.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-44631?

CVE-2026-44631 is a critical vulnerability in Apache Http Server, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Buffer Underwrite vulnerability in Apache HTTP Server on crafted regular expressions in the configuration.

This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67.

Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Weakness: CWE-124

Which versions are affected by CVE-2026-44631?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiFrom 2.4.02.4.68

Products include Apache Http Server.

How do I fix CVE-2026-44631?

Upgrade apache to 2.4.68 or later.

Is CVE-2026-44631 being exploited?

There is no known exploitation of CVE-2026-44631 in the wild and no public exploit code.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-44631, AZL-89735, BELL-CVE-2026-44631, BIT-apache-2026-44631, CLSA-2026-1782212784, CLSA-2026-1782293864 and 6 more.

Is CVE-2026-44631 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free