# CVE-2026-44634: Stack buffer overflows in SimpleBLE

> Stack buffer overflows in SimpleBLE allow remote attackers to execute arbitrary code or cause denial of service via crafted BLE advertisements.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Jun 2026
- **Updated:** 10 Jun 2026
- **Also known as:** GHSA-8h89-q8m2-c8fp

## What is CVE-2026-44634?

CVE-2026-44634 is a high-severity memory corruption vulnerability in simpleble, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SimpleBLE is a cross-platform library and bindings for Bluetooth Low Energy (BLE). Prior to version 0.14.0, there are multiple stack-based buffer overflow vulnerabilities in SimpleBLE. There is a stack overflow vulnerability in the dongl backend’s Protocol::simpleble_write function (local, caller-controlled input). A stack overflow vulnerability when processing manufacturer-specific data in BLE advertisements (remote, no pairing or connection required). Lastly, a stack overflow vulnerability when processing service data in BLE advertisements (remote, no pairing or connection required). This issue has been patched in version 0.14.0.

Weakness: CWE-787 (Out-of-bounds Write), CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-44634?


## How do I fix CVE-2026-44634?

No fix has been published for CVE-2026-44634 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44634 being exploited?

There is no known exploitation of CVE-2026-44634 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44634 and fix it if it is affected.

What it is: CVE-2026-44634 is a high-severity memory corruption vulnerability in simpleble, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44634 in the wild and no public exploit code.

Affected product: simpleble. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44634/ (Markdown: https://insights.sbomify.com/CVE-2026-44634/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44634
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44634
- OSV: https://osv.dev/vulnerability/CVE-2026-44634

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44634/
Summaries are generated and may contain mistakes; the official description above is the record.
