{"answers":{"affected":"2 open source packages ship an affected version, including kysely.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44635 exists.","fix":"Upgrade kysely to 0.28.17 or later.","what":"CVE-2026-44635 is a high-severity path traversal vulnerability in kysely-org kysely, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44635 and fix it if it is affected.\n\nWhat it is: CVE-2026-44635 is a high-severity path traversal vulnerability in kysely-org kysely, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44635 exists.\n\nAffected packages and fixed versions:\n- kysely (npm): affected from 0.26.0; fixed in 0.28.17\n- kysely (npm): affected from 0.26.0; fixed in 0.28.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44635/ (Markdown: https://insights.sbomify.com/CVE-2026-44635/index.md)","id":"CVE-2026-44635","markdown":"https://insights.sbomify.com/CVE-2026-44635/index.md","name":"CVE-2026-44635","record":{"aliases":["GHSA-pv5w-4p9q-p3v2","MINI-86x4-jc2c-g6h2","MINI-q9x3-hh68-rr8f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"TypeScript SQL query builder","requires_auth":"none","summary":"Attackers can traverse JSON sub-fields outside intended scope via unsanitized path metacharacters in Kysely query builder, leading to unauthorized data access or modification.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-915","name":"Improperly Controlled Modification of Dynamically-Determined Object Attributes"},{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"}],"description":"Kysely is a type-safe TypeScript SQL query builder. From 0.26.0 to 0.28.16, DefaultQueryCompiler.visitJSONPathLeg does not escape JSON-path metacharacters (., [, ], *, **, ?). When attacker-controlled input flows into eb.ref(col, '-\u003e$').key(input) or .at(input) — including type-safe code where the JSON column is shaped like Record\u003cstring, T\u003e so K extends string is the inferred type — every dot becomes a path-leg separator, letting an attacker traverse from the intended key into sibling and child fields the developer never meant to expose. The result is read access (and, in update statements, write access) to JSON sub-fields outside the intended scope across MySQL, PostgreSQL -\u003e$/-\u003e\u003e$, and SQLite. This vulnerability is fixed in 0.28.17.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Kysely: JSON-path traversal injection via unsanitized path-leg metacharacters in `JSONPathBuilder.key()` / `.at()`","id":"CVE-2026-44635","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"libsixel: integer overflow in encoder","id":"CVE-2026-44636"},"packages":[{"ecosystem":"npm","fixed":["0.28.17"],"introduced":["0.26.0"],"last_affected":[],"package":"kysely","purl":null,"source":"GHSA-pv5w-4p9q-p3v2"},{"ecosystem":"npm","fixed":["0.28.17"],"introduced":["0.26.0"],"last_affected":[],"package":"kysely","purl":"pkg:npm/kysely","source":"GHSA-pv5w-4p9q-p3v2"}],"prev":{"headline":"Stack buffer overflows in SimpleBLE","id":"CVE-2026-44634"},"products":["kysely"],"published":"2026-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-28","vendors":["kysely-org"]},"summary":"Attackers can traverse JSON sub-fields outside intended scope via unsanitized path metacharacters in Kysely query builder, leading to unauthorized data access or modification.","url":"https://insights.sbomify.com/CVE-2026-44635/"}