{"answers":{"affected":"3 open source packages ship an affected version, including apm-cli.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44641 exists.","fix":"Upgrade apm-cli to 0.8.12 or later.","what":"CVE-2026-44641 is a high-severity path traversal vulnerability in microsoft apm, published on 15 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44641 and fix it if it is affected.\n\nWhat it is: CVE-2026-44641 is a high-severity path traversal vulnerability in microsoft apm, published on 15 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44641 exists.\n\nAffected packages and fixed versions:\n- apm-cli (PyPI): affected all versions; fixed in 0.8.12\n- apm-cli (PyPI): affected all versions; fixed in 0.8.12\n- apm-cli (PyPI): affected all versions; fixed in 0.8.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44641/ (Markdown: https://insights.sbomify.com/CVE-2026-44641/index.md)","id":"CVE-2026-44641","markdown":"https://insights.sbomify.com/CVE-2026-44641/index.md","name":"CVE-2026-44641","record":{"aliases":["GHSA-xhrw-5qxx-jpwr","PYSEC-2026-2379"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Microsoft APM","requires_auth":"none","summary":"A malicious plugin can use path traversal in plugin.json to copy arbitrary host files during installation, allowing attackers to read sensitive data.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-73","name":"External Control of File Name or Path"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Microsoft APM is an open-source, community-driven dependency manager for AI agents. Prior to 0.8.12, Microsoft APM normalizes marketplace plugins by copying plugin components referenced in plugin.json into .apm/. The manifest fields agents, skills, commands, and hooks are attacker-controlled, but the implementation does not enforce that those paths remain inside the plugin directory. A malicious plugin can therefore use absolute paths or ../ traversal paths to copy arbitrary readable host files or directories from the installer's machine during apm install. This vulnerability is fixed in 0.8.12.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Microsoft APM: plugin.json component paths escape plugin root and copy arbitrary host files during install","id":"CVE-2026-44641","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Piwigo: SQL injection in upgrade authentication allows unauthenticated upgrade authorization bypass (PHP 8+)","id":"CVE-2026-44642"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.12"],"introduced":["0"],"last_affected":[],"package":"apm-cli","purl":null,"source":"GHSA-xhrw-5qxx-jpwr"},{"ecosystem":"PyPI","fixed":["0.8.12"],"introduced":["0"],"last_affected":[],"package":"apm-cli","purl":"pkg:pypi/apm-cli","source":"GHSA-xhrw-5qxx-jpwr"},{"ecosystem":"PyPI","fixed":["0.8.12"],"introduced":["0"],"last_affected":[],"package":"apm-cli","purl":"pkg:pypi/apm-cli","source":"PYSEC-2026-2379"}],"prev":{"headline":"NanoMQ: QUIC Dialer Close Type Confusion","id":"CVE-2026-44640"},"products":["apm"],"published":"2026-05-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-15","vendors":["microsoft"]},"summary":"A malicious plugin can use path traversal in plugin.json to copy arbitrary host files during installation, allowing attackers to read sensitive data.","url":"https://insights.sbomify.com/CVE-2026-44641/"}