# CVE-2026-44642: Piwigo: SQL injection in upgrade authentication allows unauthenticated upgrade authorization bypass (PHP 8+)

> Unauthenticated attackers can bypass upgrade authorization via SQL injection in Piwigo, leading to unauthorized database changes and service disruption.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** GHSA-6wj3-7fhw-gfpm

## What is CVE-2026-44642?

CVE-2026-44642 is a high-severity SQL injection vulnerability in Piwigo, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Piwigo is a full featured open source photo gallery application for the web. Prior to 16.4.0, check_upgrade_access_rights() in admin/include/functions_upgrade.php conditionally escapes the submitted username only when the removed get_magic_quotes_gpc function exists, so PHP 8 and later concatenate an unauthenticated username directly into the upgrade authentication SQL query. When database upgrades are pending, a crafted query result can satisfy the status and password checks, set PHPWG_IN_UPGRADE, and authorize upgrade execution without valid administrator credentials. This can cause unauthorized database integrity changes and service disruption. This vulnerability is fixed in 16.4.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-44642?


## How do I fix CVE-2026-44642?

No fix has been published for CVE-2026-44642 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44642 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44642 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44642 and fix it if it is affected.

What it is: CVE-2026-44642 is a high-severity SQL injection vulnerability in Piwigo, published on 25 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44642 exists.

Affected product: Piwigo. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44642/ (Markdown: https://insights.sbomify.com/CVE-2026-44642/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44642
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44642
- OSV: https://osv.dev/vulnerability/CVE-2026-44642

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44642/
Summaries are generated and may contain mistakes; the official description above is the record.
