{"answers":{"affected":"2 open source packages ship an affected version, including angular-expressions. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-44643 in the wild and no public exploit code.","fix":"Upgrade angular-expressions to 1.5.2 or later.","what":"CVE-2026-44643 is a critical code injection vulnerability in peerigon angular-expressions, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44643 and fix it if it is affected.\n\nWhat it is: CVE-2026-44643 is a critical code injection vulnerability in peerigon angular-expressions, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44643 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- angular-expressions (npm): affected all versions; fixed in 1.5.2\n- angular-expressions (npm): affected all versions; fixed in 1.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44643/ (Markdown: https://insights.sbomify.com/CVE-2026-44643/index.md)","id":"CVE-2026-44643","markdown":"https://insights.sbomify.com/CVE-2026-44643/index.md","name":"CVE-2026-44643","record":{"aliases":["GHSA-pw8r-6689-xvf4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Angular expressions library","requires_auth":"none","summary":"An attacker can execute arbitrary code on the system by injecting malicious expressions using filters in the Angular Expressions library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"angular-expressions","vendor":"peerigon"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"Angular Expressions provides expressions for the Angular.JS web framework as a standalone module. Prior to 1.5.2, an attacker can write a malicious expression using filters that escapes the sandbox to execute arbitrary code on the system. This vulnerability is fixed in 1.5.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Angular Expressions - Remote Code Execution using filters","id":"CVE-2026-44643","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"LiquidJS's strip_html filter bypass via newline characters in HTML tags enables XSS","id":"CVE-2026-44644"},"packages":[{"ecosystem":"npm","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"angular-expressions","purl":null,"source":"GHSA-pw8r-6689-xvf4"},{"ecosystem":"npm","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"angular-expressions","purl":"pkg:npm/angular-expressions","source":"GHSA-pw8r-6689-xvf4"}],"prev":{"headline":"Piwigo: SQL injection in upgrade authentication allows unauthenticated upgrade authorization bypass (PHP 8+)","id":"CVE-2026-44642"},"products":["angular-expressions"],"published":"2026-05-11","related":[{"cvss_score":8.7,"headline":"Remote Code Execution in Angular Expressions","id":"CVE-2020-5219","kev_date_added":null,"published":"2020-01-24"},{"cvss_score":8.5,"headline":"Angular Expressions - Remote Code Execution","id":"CVE-2021-21277","kev_date_added":null,"published":"2021-02-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-11","vendors":["peerigon"]},"summary":"An attacker can execute arbitrary code on the system by injecting malicious expressions using filters in the Angular Expressions library.","url":"https://insights.sbomify.com/CVE-2026-44643/"}