# CVE-2026-44643: Angular Expressions - Remote Code Execution using filters

> An attacker can execute arbitrary code on the system by injecting malicious expressions using filters in the Angular Expressions library.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-pw8r-6689-xvf4

## What is CVE-2026-44643?

CVE-2026-44643 is a critical code injection vulnerability in peerigon angular-expressions, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Angular Expressions provides expressions for the Angular.JS web framework as a standalone module. Prior to 1.5.2, an attacker can write a malicious expression using filters that escapes the sandbox to execute arbitrary code on the system. This vulnerability is fixed in 1.5.2.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2026-44643?

2 open source packages ship an affected version, including angular-expressions. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `angular-expressions` | npm | All versions | 1.5.2 |
| `angular-expressions` | npm | All versions | 1.5.2 |

Products: Peerigon Angular-Expressions.

## How do I fix CVE-2026-44643?

Upgrade angular-expressions to 1.5.2 or later.

## Is CVE-2026-44643 being exploited?

There is no known exploitation of CVE-2026-44643 in the wild and no public exploit code.

## Other vulnerabilities in peerigon angular-expressions

- [CVE-2020-5219](https://insights.sbomify.com/CVE-2020-5219/): Remote Code Execution in Angular Expressions (high 8.7)
- [CVE-2021-21277](https://insights.sbomify.com/CVE-2021-21277/): Angular Expressions - Remote Code Execution (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44643 and fix it if it is affected.

What it is: CVE-2026-44643 is a critical code injection vulnerability in peerigon angular-expressions, published on 11 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44643 in the wild and no public exploit code.

Affected packages and fixed versions:
- angular-expressions (npm): affected all versions; fixed in 1.5.2
- angular-expressions (npm): affected all versions; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44643/ (Markdown: https://insights.sbomify.com/CVE-2026-44643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44643
- OSV: https://osv.dev/vulnerability/CVE-2026-44643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44643/
Summaries are generated and may contain mistakes; the official description above is the record.
