{"answers":{"affected":"2 open source packages ship an affected version, including sillytavern.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44648 exists.","fix":"Upgrade sillytavern to 1.18.0 or later.","what":"CVE-2026-44648 is a high-severity authentication bypass vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44648 and fix it if it is affected.\n\nWhat it is: CVE-2026-44648 is a high-severity authentication bypass vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44648 exists.\n\nAffected packages and fixed versions:\n- sillytavern (npm): affected all versions; fixed in 1.18.0\n- sillytavern (npm): affected all versions; fixed in 1.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44648/ (Markdown: https://insights.sbomify.com/CVE-2026-44648/index.md)","id":"CVE-2026-44648","markdown":"https://insights.sbomify.com/CVE-2026-44648/index.md","name":"CVE-2026-44648","record":{"aliases":["GHSA-wmm3-h9qj-p5v6"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"SillyTavern UI","requires_auth":"none","summary":"Attackers can reuse existing session cookies after a password change to maintain access and take over accounts in SillyTavern.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. Prior to 1.18.0, SillyTavern relies on cookie-session for authentication, storing all session data (user handle, permissions) in a signed cookie. The endpoints POST /api/users/change-password and POST /api/users/recover-step2 only update the password hash in the database but do not expire current sessions. Because the session is stateless and stored entirely in the client cookie, there is no server-side mechanism to revoke a token once issued. This vulnerability is fixed in 1.18.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2026-05-08","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-08T03:35:57Z","kind":"github_poc","ref":"https://github.com/zzzm0919/CVE-2026-44648","stars":0,"title":"PoC and advisory for CVE-2026-44648"}],"tier":"weaponised"},"has_fix":true,"headline":"SillyTavern: Existing sessions are not invalidated after password change, allowing session reuse and account takeover","id":"CVE-2026-44648","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"SillyTavern: Authentication Bypass via SSO Header Injection","id":"CVE-2026-44649"},"packages":[{"ecosystem":"npm","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"sillytavern","purl":null,"source":"GHSA-wmm3-h9qj-p5v6"},{"ecosystem":"npm","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"sillytavern","purl":"pkg:npm/sillytavern","source":"GHSA-wmm3-h9qj-p5v6"}],"prev":{"headline":"OneDev: Path Traversal (read capability via Git LFS pointer resolution)","id":"CVE-2026-44647"},"products":["SillyTavern"],"published":"2026-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-29","vendors":["SillyTavern"]},"summary":"Attackers can reuse existing session cookies after a password change to maintain access and take over accounts in SillyTavern.","url":"https://insights.sbomify.com/CVE-2026-44648/"}