{"answers":{"affected":"2 open source packages ship an affected version, including sillytavern.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44650 exists.","fix":"Upgrade sillytavern to 1.18.0 or later.","what":"CVE-2026-44650 is a critical path traversal vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44650 and fix it if it is affected.\n\nWhat it is: CVE-2026-44650 is a critical path traversal vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44650 exists.\n\nAffected packages and fixed versions:\n- sillytavern (npm): affected all versions; fixed in 1.18.0\n- sillytavern (npm): affected all versions; fixed in 1.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44650/ (Markdown: https://insights.sbomify.com/CVE-2026-44650/index.md)","id":"CVE-2026-44650","markdown":"https://insights.sbomify.com/CVE-2026-44650/index.md","name":"CVE-2026-44650","record":{"aliases":["GHSA-886q-f44j-h6wh"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_modify","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SillyTavern UI","requires_auth":"none","summary":"An unauthenticated attacker can delete the entire user extensions directory by sending a crafted request to the SillyTavern API.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. Prior to 1.18.0, POST /api/extensions/delete endpoint accepts extensionName: \".\" which bypasses sanitize-filename validation, causing the entire user extensions directory to be recursively deleted. No authentication is required in the default configuration. This vulnerability is fixed in 1.18.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"SillyTavern: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')","id":"CVE-2026-44650","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"SillyTavern: Reflected XSS vulnerability in the CORS proxy middleware","id":"CVE-2026-44651"},"packages":[{"ecosystem":"npm","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"sillytavern","purl":null,"source":"GHSA-886q-f44j-h6wh"},{"ecosystem":"npm","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"sillytavern","purl":"pkg:npm/sillytavern","source":"GHSA-886q-f44j-h6wh"}],"prev":{"headline":"SillyTavern: Authentication Bypass via SSO Header Injection","id":"CVE-2026-44649"},"products":["SillyTavern"],"published":"2026-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-29","vendors":["SillyTavern"]},"summary":"An unauthenticated attacker can delete the entire user extensions directory by sending a crafted request to the SillyTavern API.","url":"https://insights.sbomify.com/CVE-2026-44650/"}