# CVE-2026-44650: SillyTavern: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

> An unauthenticated attacker can delete the entire user extensions directory by sending a crafted request to the SillyTavern API.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-886q-f44j-h6wh

## What is CVE-2026-44650?

CVE-2026-44650 is a critical path traversal vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. Prior to 1.18.0, POST /api/extensions/delete endpoint accepts extensionName: "." which bypasses sanitize-filename validation, causing the entire user extensions directory to be recursively deleted. No authentication is required in the default configuration. This vulnerability is fixed in 1.18.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-44650?

2 open source packages ship an affected version, including sillytavern.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sillytavern` | npm | All versions | 1.18.0 |
| `sillytavern` | npm | All versions | 1.18.0 |

## How do I fix CVE-2026-44650?

Upgrade sillytavern to 1.18.0 or later.

## Is CVE-2026-44650 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44650 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44650 and fix it if it is affected.

What it is: CVE-2026-44650 is a critical path traversal vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44650 exists.

Affected packages and fixed versions:
- sillytavern (npm): affected all versions; fixed in 1.18.0
- sillytavern (npm): affected all versions; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44650/ (Markdown: https://insights.sbomify.com/CVE-2026-44650/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44650
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44650
- OSV: https://osv.dev/vulnerability/CVE-2026-44650

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44650/
Summaries are generated and may contain mistakes; the official description above is the record.
