{"answers":{"affected":"2 open source packages ship an affected version, including sillytavern.","exploited":"There is no known exploitation of CVE-2026-44651 in the wild and no public exploit code.","fix":"Upgrade sillytavern to 1.18.0 or later.","what":"CVE-2026-44651 is a medium-severity cross-site scripting vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44651 and fix it if it is affected.\n\nWhat it is: CVE-2026-44651 is a medium-severity cross-site scripting vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44651 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sillytavern (npm): affected all versions; fixed in 1.18.0\n- sillytavern (npm): affected all versions; fixed in 1.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44651/ (Markdown: https://insights.sbomify.com/CVE-2026-44651/index.md)","id":"CVE-2026-44651","markdown":"https://insights.sbomify.com/CVE-2026-44651/index.md","name":"CVE-2026-44651","record":{"aliases":["GHSA-xc4x-2452-5gc9"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"SillyTavern UI","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the victim's browser via reflected XSS in the CORS proxy error handling of SillyTavern.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. Prior to 1.18.0, when fetch(url) throws, the code sends:\nres.status(500).send('Error occurred while trying to proxy to: ' + url + ' ' + error). The url value is attacker-controlled (req.params.url) and is not HTML-escaped before rendering. This vulnerability is fixed in 1.18.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SillyTavern: Reflected XSS vulnerability in the CORS proxy middleware","id":"CVE-2026-44651","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"SillyTavern: SSRF vulnerability in the CORS proxy middleware","id":"CVE-2026-44652"},"packages":[{"ecosystem":"npm","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"sillytavern","purl":null,"source":"GHSA-xc4x-2452-5gc9"},{"ecosystem":"npm","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"sillytavern","purl":"pkg:npm/sillytavern","source":"GHSA-xc4x-2452-5gc9"}],"prev":{"headline":"SillyTavern: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')","id":"CVE-2026-44650"},"products":["SillyTavern"],"published":"2026-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-01","vendors":["SillyTavern"]},"summary":"An attacker can execute arbitrary scripts in the victim's browser via reflected XSS in the CORS proxy error handling of SillyTavern.","url":"https://insights.sbomify.com/CVE-2026-44651/"}