# CVE-2026-44651: SillyTavern: Reflected XSS vulnerability in the CORS proxy middleware

> An attacker can execute arbitrary scripts in the victim's browser via reflected XSS in the CORS proxy error handling of SillyTavern.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-xc4x-2452-5gc9

## What is CVE-2026-44651?

CVE-2026-44651 is a medium-severity cross-site scripting vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. Prior to 1.18.0, when fetch(url) throws, the code sends:
res.status(500).send('Error occurred while trying to proxy to: ' + url + ' ' + error). The url value is attacker-controlled (req.params.url) and is not HTML-escaped before rendering. This vulnerability is fixed in 1.18.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-44651?

2 open source packages ship an affected version, including sillytavern.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sillytavern` | npm | All versions | 1.18.0 |
| `sillytavern` | npm | All versions | 1.18.0 |

## How do I fix CVE-2026-44651?

Upgrade sillytavern to 1.18.0 or later.

## Is CVE-2026-44651 being exploited?

There is no known exploitation of CVE-2026-44651 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44651 and fix it if it is affected.

What it is: CVE-2026-44651 is a medium-severity cross-site scripting vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44651 in the wild and no public exploit code.

Affected packages and fixed versions:
- sillytavern (npm): affected all versions; fixed in 1.18.0
- sillytavern (npm): affected all versions; fixed in 1.18.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44651/ (Markdown: https://insights.sbomify.com/CVE-2026-44651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44651
- OSV: https://osv.dev/vulnerability/CVE-2026-44651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44651/
Summaries are generated and may contain mistakes; the official description above is the record.
