{"answers":{"affected":"2 open source packages ship an affected version, including sillytavern.","exploited":"There is no known exploitation of CVE-2026-44652 in the wild and no public exploit code.","fix":"Upgrade sillytavern to 1.18.0 or later.","what":"CVE-2026-44652 is a medium-severity server-side request forgery vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44652 and fix it if it is affected.\n\nWhat it is: CVE-2026-44652 is a medium-severity server-side request forgery vulnerability in SillyTavern, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44652 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sillytavern (npm): affected all versions; fixed in 1.18.0\n- sillytavern (npm): affected all versions; fixed in 1.18.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44652/ (Markdown: https://insights.sbomify.com/CVE-2026-44652/index.md)","id":"CVE-2026-44652","markdown":"https://insights.sbomify.com/CVE-2026-44652/index.md","name":"CVE-2026-44652","record":{"aliases":["GHSA-ccfq-2454-f5xw"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM user interface","requires_auth":"none","summary":"Attackers can exploit the CORS proxy to perform Server-Side Request Forgery, accessing internal resources or bypassing network restrictions.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"SillyTavern is a locally installed user interface that allows users to interact with text generation large language models, image generation engines, and text-to-speech voice models. Prior to 1.18.0, corsProxyMiddleware forwards req.params.url directly into fetch(url, ...). It only blocks circular requests to its own host and does not enforce destination allowlist or private/loopback restrictions, enabling SSRF. This vulnerability is fixed in 1.18.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SillyTavern: SSRF vulnerability in the CORS proxy middleware","id":"CVE-2026-44652","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"LibreChat Shared MCP Server View Leaks Decrypted Admin Secrets","id":"CVE-2026-44653"},"packages":[{"ecosystem":"npm","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"sillytavern","purl":null,"source":"GHSA-ccfq-2454-f5xw"},{"ecosystem":"npm","fixed":["1.18.0"],"introduced":["0"],"last_affected":[],"package":"sillytavern","purl":"pkg:npm/sillytavern","source":"GHSA-ccfq-2454-f5xw"}],"prev":{"headline":"SillyTavern: Reflected XSS vulnerability in the CORS proxy middleware","id":"CVE-2026-44651"},"products":["SillyTavern"],"published":"2026-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-29","vendors":["SillyTavern"]},"summary":"Attackers can exploit the CORS proxy to perform Server-Side Request Forgery, accessing internal resources or bypassing network restrictions.","url":"https://insights.sbomify.com/CVE-2026-44652/"}