{"answers":{"affected":"2 open source packages ship an affected version, including openssl.","exploited":"There is no known exploitation of CVE-2026-44662 in the wild and no public exploit code.","fix":"Upgrade openssl to 0.10.79 or later.","what":"CVE-2026-44662 is a medium-severity memory corruption vulnerability in rust-openssl, published on 14 May 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44662 and fix it if it is affected.\n\nWhat it is: CVE-2026-44662 is a medium-severity memory corruption vulnerability in rust-openssl, published on 14 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44662 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openssl (crates.io): affected from 0.10.0; fixed in 0.10.79\n- openssl (crates.io): affected from 0.10.0; fixed in 0.10.79\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44662/ (Markdown: https://insights.sbomify.com/CVE-2026-44662/index.md)","id":"CVE-2026-44662","markdown":"https://insights.sbomify.com/CVE-2026-44662/index.md","name":"CVE-2026-44662","record":{"aliases":["AZL-86814","DEBIAN-CVE-2026-44662","GHSA-xv59-967r-8726","MINI-4r32-rqmm-pmq9","MINI-63mx-9wpq-j56f","MINI-f736-9qrg-gr68","MINI-hp2q-gvcj-gqgq","MINI-m888-vqp5-9wp4","MINI-mf2c-6hjx-6349","MINI-pxc4-9pxv-qr9c","MINI-wcq8-gww5-3rv3","MINI-xx7x-xcf3-gf5h","UBUNTU-CVE-2026-44662"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Rust OpenSSL bindings","requires_auth":"none","summary":"Heap buffer overflow in rust-openssl allows attacker-controlled corruption when using AES key-wrap-with-padding, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.10.0 to before 0.10.79, CipherCtxRef::cipher_update, CipherCtxRef::cipher_update_vec, and symm::Crypter::update incorrectly sized output buffers when used with AES key-wrap-with-padding ciphers (EVP_aes_{128,192,256}_wrap_pad). For a non-multiple-of-8 input, OpenSSL writes up to 7 bytes past the end of the caller's buffer or Vec, producing attacker-controllable heap corruption when the plaintext length is attacker-influenced. This only impacts users using AES key-wrap-with-padding ciphers. This vulnerability is fixed in 0.10.79.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rust-openssl: Heap buffer overflow when encrypting with AES key-wrap-with-padding","id":"CVE-2026-44662","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"OpenEXR: Integer overflow in the HTJ2K decoder leads to heap-buffer-overflow","id":"CVE-2026-44663"},"packages":[{"ecosystem":"crates.io","fixed":["0.10.79"],"introduced":["0.10.0"],"last_affected":[],"package":"openssl","purl":null,"source":"GHSA-xv59-967r-8726"},{"ecosystem":"crates.io","fixed":["0.10.79"],"introduced":["0.10.0"],"last_affected":[],"package":"openssl","purl":"pkg:cargo/openssl","source":"GHSA-xv59-967r-8726"}],"prev":{"headline":"python-utcp: SSRF via attacker-controlled OpenAPI servers[0].url in HTTP communication protocol","id":"CVE-2026-44661"},"products":["rust-openssl"],"published":"2026-05-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-16","vendors":["rust-openssl"]},"summary":"Heap buffer overflow in rust-openssl allows attacker-controlled corruption when using AES key-wrap-with-padding, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2026-44662/"}