# CVE-2026-44663: OpenEXR: Integer overflow in the HTJ2K decoder leads to heap-buffer-overflow

> An integer overflow in the HTJ2K decoder allows attackers to trigger a heap-buffer overflow via crafted EXR files, potentially leading to code execution or crashes.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** BELL-CVE-2026-44663, DEBIAN-CVE-2026-44663, GHSA-777r-f9x8-7r84, JLSEC-2026-812, UBUNTU-CVE-2026-44663

## What is CVE-2026-44663?

CVE-2026-44663 is a medium-severity vulnerability in Openexr Openexr, published on 18 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. In versions 3.4.0 through 3.4.11, an integer overflow in ht_undo_impl() in src/lib/OpenEXRCore/internal_ht.cpp leads to a heap-buffer overflow when decoding a crafted HTJ2K-compressed EXR file. decode->channels[i].width (int32_t) is multiplied by bytes_per_element in 32-bit signed arithmetic. With large widths (e.g., >= 536870912 for FLOAT data), this overflows, producing a corrupted offset that is later used for pointer arithmetic and can cause a heap out-of-bounds write. The same unchecked multiplication pattern appears in two other HTJ2K paths (bytes-per-line accumulation and pixel-line pointer advancement). As with related CVE-2026-34378 through CVE-2026-34589 fixes in other codecs, validating only after the multiplication is too late because the value may already be overflowed. This issue has been fixed in version 3.4.12.

Weakness: CWE-787 (Out-of-bounds Write), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-44663?

It affects 1 product.


Products: Openexr Openexr.

## How do I fix CVE-2026-44663?

Upgrade to a fixed version.

## Is CVE-2026-44663 being exploited?

There is no known exploitation of CVE-2026-44663 in the wild and no public exploit code.

## Other vulnerabilities in Openexr Openexr

- [CVE-2023-5841](https://insights.sbomify.com/CVE-2023-5841/): OpenEXR Heap Overflow in Scanline Deep Data Parsing (critical 9.1)
- [CVE-2026-41142](https://insights.sbomify.com/CVE-2026-41142/): OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API (high 8.8)
- [CVE-2026-42216](https://insights.sbomify.com/CVE-2026-42216/): OpenEXR: Out-of-bounds read in `IDManifest::init()` during prefix expansion (high 8.8)
- [CVE-2017-9111](https://insights.sbomify.com/CVE-2017-9111/): OpenEXR invalid write (high 8.8)
- [CVE-2017-9113](https://insights.sbomify.com/CVE-2017-9113/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44663 and fix it if it is affected.

What it is: CVE-2026-44663 is a medium-severity vulnerability in Openexr Openexr, published on 18 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44663 in the wild and no public exploit code.

Affected product: Openexr Openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44663/ (Markdown: https://insights.sbomify.com/CVE-2026-44663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44663
- OSV: https://osv.dev/vulnerability/CVE-2026-44663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44663/
Summaries are generated and may contain mistakes; the official description above is the record.
