# CVE-2026-44664: fast-xml-builder: Comment Value bypass regex

> An attacker can inject arbitrary XML or HTML content by bypassing comment sanitization, potentially leading to cross-site scripting or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 13 May 2026
- **Also known as:** ECHO-7046-085f-179a, GHSA-45c6-75p6-83cc, MINI-7qqw-r5m9-38gm, MINI-83f7-qrgh-ghfj, MINI-9jf8-mcg2-r99q, MINI-gmgf-4mg5-fqrq, MINI-hx5x-4j49-353x, MINI-jvpw-h8mf-7c6p, MINI-q4hx-mhw7-rhp8, MINI-x622-wv53-hh9r, ROOT-APP-NPM-CVE-2026-44664

## What is CVE-2026-44664?

CVE-2026-44664 is a medium-severity cross-site scripting vulnerability in NaturalIntelligence fast-xml-builder, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

fast-xml-builder builds XML from JSON. In 1.1.5, the fix for CVE-2026-41650 in fast-xml-parser sanitizes -- sequences in XML comment content using .replace(/--/g, '- -'). This skip the values containing three consecutive dashes (e.g., --->...), allowing an attacker to break out of an XML comment and inject arbitrary XML/HTML content. This vulnerability is fixed in 1.1.6.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2026-44664?

2 open source packages ship an affected version, including fast-xml-builder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-xml-builder` | npm | From 1.1.5 | 1.1.6 |
| `fast-xml-builder` | npm | From 1.1.5 | 1.1.6 |

## How do I fix CVE-2026-44664?

Upgrade fast-xml-builder to 1.1.6 or later.

## Is CVE-2026-44664 being exploited?

There is no known exploitation of CVE-2026-44664 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44664 and fix it if it is affected.

What it is: CVE-2026-44664 is a medium-severity cross-site scripting vulnerability in NaturalIntelligence fast-xml-builder, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44664 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-xml-builder (npm): affected from 1.1.5; fixed in 1.1.6
- fast-xml-builder (npm): affected from 1.1.5; fixed in 1.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44664/ (Markdown: https://insights.sbomify.com/CVE-2026-44664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44664
- OSV: https://osv.dev/vulnerability/CVE-2026-44664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44664/
Summaries are generated and may contain mistakes; the official description above is the record.
