# CVE-2026-44681: Authlib: Open Redirect in Authlib OIDC Implicit/Hybrid Authorization

> An unauthenticated open redirect in Authlib's OIDC authorization endpoint allows attackers to redirect users to malicious URLs.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 2 Jun 2026
- **Also known as:** CLEANSTART-2026-HL24999, CLEANSTART-2026-UZ98242, DEBIAN-CVE-2026-44681, ECHO-abd9-179e-e8ab, GHSA-r95x-qfjj-fjj2, MINI-pgrm-6cg6-9cp7, MINI-v5w2-r7mg-2ppx, PYSEC-2026-188, ROOT-APP-PYPI-CVE-2026-44681, UBUNTU-CVE-2026-44681, openSUSE-SU-2026:10883-1

## What is CVE-2026-44681?

CVE-2026-44681 is a medium-severity vulnerability in authlib, published on 27 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to 1.6.12 and 1.7.1, an unauthenticated open redirect in Authlib's OpenIDImplicitGrant and OpenIDHybridGrant authorization endpoint lets a remote attacker cause the authorization server to issue an HTTP 302 to an attacker-chosen URL by submitting an authorization request that omits the openid scope. This vulnerability is fixed in 1.6.12 and 1.7.1.

Weakness: CWE-863 (Incorrect Authorization), CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-44681?

5 open source packages ship an affected version, including authlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authlib` | PyPI | All versions | 1.6.12 |
| `authlib` | PyPI | All versions | 1.6.12 |
| `authlib` | PyPI | All versions | 1.6.12 |
| `authlib` | PyPI | From 1.7.0 | 1.7.1 |
| `authlib` | PyPI | From 1.7.0 | 1.7.1 |
| `python-Authlib` | openSUSE:Tumbleweed | All versions | 1.7.2-1.1 |

Products: Authlib Authlib.

## How do I fix CVE-2026-44681?

Upgrade authlib to a fixed version for your release line: 1.6.12 or 1.7.1.

## Is CVE-2026-44681 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44681 exists.

## Other vulnerabilities in authlib

- [CVE-2026-27962](https://insights.sbomify.com/CVE-2026-27962/): Authlib JWS JWK Header Injection: Signature Verification Bypass (critical 9.1)
- [CVE-2026-28490](https://insights.sbomify.com/CVE-2026-28490/): Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle (high 8.3)
- [CVE-2026-28498](https://insights.sbomify.com/CVE-2026-28498/): Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding (high 8.2)
- [CVE-2026-28802](https://insights.sbomify.com/CVE-2026-28802/): Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification (high 7.7)
- [CVE-2025-61920](https://insights.sbomify.com/CVE-2025-61920/): Authlib is vulnerable to Denial of Service via Oversized JOSE Segments (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44681 and fix it if it is affected.

What it is: CVE-2026-44681 is a medium-severity vulnerability in authlib, published on 27 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44681 exists.

Affected packages and fixed versions:
- authlib (PyPI): affected all versions; fixed in 1.6.12
- authlib (PyPI): affected all versions; fixed in 1.6.12
- authlib (PyPI): affected all versions; fixed in 1.6.12
- authlib (PyPI): affected from 1.7.0; fixed in 1.7.1
- authlib (PyPI): affected from 1.7.0; fixed in 1.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44681/ (Markdown: https://insights.sbomify.com/CVE-2026-44681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44681
- OSV: https://osv.dev/vulnerability/CVE-2026-44681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44681/
Summaries are generated and may contain mistakes; the official description above is the record.
