# CVE-2026-44709: pam_usb: PINENTRY_FALLBACK_APP environment variable allows arbitrary command execution

> Attackers can execute arbitrary commands with elevated privileges by manipulating the PINENTRY_FALLBACK_APP environment variable in pam_usb.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 May 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-jxrj-q67x-wr4c

## What is CVE-2026-44709?

CVE-2026-44709 is a high-severity command injection vulnerability in mcdope pam_usb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.8.7, pamusb-pinentry reads the PINENTRY_FALLBACK_APP environment variable and executes it directly without any validation. Any process that can set environment variables before pamusb-pinentry is invoked can point PINENTRY_FALLBACK_APP at an arbitrary binary or script and have it executed with the privileges of the pam_usb tool chain. This vulnerability is fixed in 0.8.7.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-44709?


## How do I fix CVE-2026-44709?

No fix has been published for CVE-2026-44709 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44709 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44709 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44709 and fix it if it is affected.

What it is: CVE-2026-44709 is a high-severity command injection vulnerability in mcdope pam_usb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44709 exists.

Affected product: mcdope pam_usb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44709/ (Markdown: https://insights.sbomify.com/CVE-2026-44709/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44709
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44709
- OSV: https://osv.dev/vulnerability/CVE-2026-44709

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44709/
Summaries are generated and may contain mistakes; the official description above is the record.
