# CVE-2026-44710: pam_usb: NULL pointer dereference from UDisks device fields causes PAM crash and login denial-of-service

> A NULL pointer dereference in pam_usb causes a crash when handling removable media, leading to a denial-of-service condition for system logins.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-j8cq-2gv6-gfwf

## What is CVE-2026-44710?

CVE-2026-44710 is a medium-severity vulnerability in mcdope pam_usb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.8.7, src/device.c passed the return values of udisks_drive_get_serial(), udisks_drive_get_vendor(), and udisks_drive_get_model() directly to strcmp() without NULL checks. The GIO/UDisks API documentation states these accessors can return NULL for devices that do not expose the corresponding field. Passing NULL to strcmp() is undefined behaviour (typically a SIGSEGV). This vulnerability is fixed in 0.8.7.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-44710?


## How do I fix CVE-2026-44710?

No fix has been published for CVE-2026-44710 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44710 being exploited?

There is no known exploitation of CVE-2026-44710 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44710 and fix it if it is affected.

What it is: CVE-2026-44710 is a medium-severity vulnerability in mcdope pam_usb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44710 in the wild and no public exploit code.

Affected product: mcdope pam_usb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44710/ (Markdown: https://insights.sbomify.com/CVE-2026-44710/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44710
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44710
- OSV: https://osv.dev/vulnerability/CVE-2026-44710

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44710/
Summaries are generated and may contain mistakes; the official description above is the record.
