# CVE-2026-44712: pam_usb: Shell injection via device UUID and username in pamusb-conf and pamusb-agent

> Attackers can execute arbitrary commands as root via crafted USB UUIDs or usernames in pam_usb configuration files.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-jgv5-w6rm-7wxg

## What is CVE-2026-44712?

CVE-2026-44712 is a high-severity command injection vulnerability in mcdope pam_usb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.8.7, a crafted UUID such as $(id>/tmp/rce) in the config causes root RCE when pamusb-conf --reset-pads is run. A USB device with a crafted filesystem UUID (some controllers allow this) can inject the payload at --add-device time. Also, userName from the XML config is passed to os.system() in pamusb-agent, which invokes a shell. This vulnerability is fixed in 0.8.7.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-44712?


## How do I fix CVE-2026-44712?

No fix has been published for CVE-2026-44712 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44712 being exploited?

There is no known exploitation of CVE-2026-44712 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44712 and fix it if it is affected.

What it is: CVE-2026-44712 is a high-severity command injection vulnerability in mcdope pam_usb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44712 in the wild and no public exploit code.

Affected product: mcdope pam_usb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44712/ (Markdown: https://insights.sbomify.com/CVE-2026-44712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44712
- OSV: https://osv.dev/vulnerability/CVE-2026-44712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44712/
Summaries are generated and may contain mistakes; the official description above is the record.
