# CVE-2026-44713: pam_usb: Command injection via $TMUX environment variable leads to RCE as root

> Attackers can execute arbitrary commands as root by injecting shell syntax into the TMUX environment variable processed by the pam_usb module.

- **Severity:** High 8.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 May 2026
- **Updated:** 30 May 2026
- **Also known as:** GHSA-822m-whrh-vrj8

## What is CVE-2026-44713?

CVE-2026-44713 is a high-severity command injection vulnerability in mcdope pam_usb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

pam_usb provides hardware authentication for Linux using ordinary removable media. Prior to 0.8.7, src/tmux.c reads the user's $TMUX environment variable, splits it on commas, and interpolates the socket-path component directly into a shell command passed to popen(). Because the value is placed inside double-quotes without sanitisation, any value containing " terminates the quoted string and injects arbitrary shell syntax. popen() runs as root inside the PAM stack. This vulnerability is fixed in 0.8.7.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-44713?


## How do I fix CVE-2026-44713?

No fix has been published for CVE-2026-44713 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44713 being exploited?

There is no known exploitation of CVE-2026-44713 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44713 and fix it if it is affected.

What it is: CVE-2026-44713 is a high-severity command injection vulnerability in mcdope pam_usb, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44713 in the wild and no public exploit code.

Affected product: mcdope pam_usb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44713/ (Markdown: https://insights.sbomify.com/CVE-2026-44713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44713
- OSV: https://osv.dev/vulnerability/CVE-2026-44713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44713/
Summaries are generated and may contain mistakes; the official description above is the record.
